Knowledge Document: SACM Records in SMAX Are Not Showing

0 Likes

Environment

SMAX and containerized CMS 2022.05
 

Situation

The native SACM records are not visible in SMAX:

Cause

The configuration for kubernetes flannel is wrong. Flannel is responsible for pod subnet leasing.


Resolution

1. Check if the data requested is matching the CMS records by checking the columns menu. If the records are not matching, data can be visualized by changing the columns to be display, then the problem is different from the described.



2. Edit the flannel settings by command:

kubectl edit cm -n kube-system kube-flannel-cfg

change the type from “host-gw” to “vxlan”

3. Restart the flannel:

kubectl rollout restart ds kube-flannel-ds-amd64 -n kube-system

4. Then try add the worker node.
 

Additional Information

https://github.com/flannel-io/flannel - What is kubernetes flannel

Access UDCMD article on support portal

Labels:

Knowledge Docs
Comment List
Related
Recommended