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Knowledge Doc: After upgrade, Universal Discovery module in the UI is slow because of issues in the DB.

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Environment

UCMDB (Universal Configuration Management Database) 23.4
Oracle Database (specific to one step of the solution)
 

Situation

After the upgrade when trying to access the Universal Discovery section in the Local Client the application remains frozen for a lot of time before responds (10 minutes or more). Every click in the section to select a different job has the same behavior.
 

Cause

SQL query is slow due to Fragmentation, Outdated Statistics or Index Fragmentation.
 

Resolution

Involve DBA to perform following operations:
1. Rebuild or reorganize indexes to remove index fragmentation.
2. Gather updated statistics using Oracle's DBMS_STATS package (if using Oracle) to ensure accurate optimizer decisions. Analyze table cmdb.CCM_DISCOVERY_STATS estimate statistics sample 10 percent;' in this case.
3. Consider performing a table reorganization or shrink operation to reclaim fragmented space. For example, using truncate table instead of delete to free up the space.

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