(UCMDB) Support Tip: UCMDB to UCMDB integration got failed with timeout error


If encounting error below when pushing data from ucmdb to ucmdb:


2024-05-02 20:47:53,107 ERROR [RequestProcessorAsyncPool-1055549] - !!!FAILED!!![Operation #279711860 Name=DataInBulkOperation] interrupted due to timeout of 240 sec.

The timeout is calculated according to the minimal data-in rate of 1500 CIs/minute.

In order to increase the minimal data-in rate please change the value of "reconciliation.min.ci.rate" in UCMDB settings. com.mercury.topaz.cmdb.server.manage.rpm.StoppedException: [ErrorCode [700000] Action was cancelled.]

Thread RequestProcessorAsyncPool-1055549 interrupted


You may try the steps below

1 disable autocomplete parameter


2 make sure the query being used contains all information used in reconciliation. 



Auto-Complete is a capability that simplifies the process of pushing data from one system to another, since it’s often difficult to know the full extent of data necessary to differentiate one node from another. With autocomplete turned on, the user does not have to worry about this constraint. However, autocomplete capability can have a significant performance hit when pushing data from one system to another. Turning off “autocomplete” can dramatically speed up data replication, if the user knows how to provide sufficient information from the source to the target UCMDBs to allow for error-free reconciliation.


3 reduced the value of reconciliation.min.ci.rate. In general, 200 should be a reasonable value. 

4 check physical memory usage, heap size setting and usage, and total-threads-num value in <UCMDB_Server_Home>\lib\reconciliation.jar\services\reconciliation\service-config.xml 

If still encountering error, checking cmdb.reconciliation .XXX.log, find out which node caused issue, narrow down the query to fetch this problematic node only, enable reconciliation debug log, reproduce the issue, then send to support for further investigation. 

Best Regards, 



Support Tips/Knowledge Docs
Comment List