Created On:  07 January 2013

Problem:

Animator is not reflecting the colors you've selected in your .Xdefaults file.

Animator is the COBOL debugger on UNIX/Linux.  It operates in character-mode on a terminal.  There are various ways of invoking Animator, such as by entering the “anim” command, or by setting the COBSW=+A environment variable, or calling CBL_DEBUGBREAK from within a COBOL program, or using cross-session animation with “cobanimsrv”.

In most cases, when Animator first starts, it looks for an environment variable named DISPLAY.  If the DISPLAY environment variable is set (and appears to refer to a valid X-windows server), Animator opens a new ‘xterm’ terminal on that X server, and the user sees the xterm window appear on X-windows.  This could even be an X server on a separate machine than the UNIX/Linux machine where the COBOL program is running.  If DISPLAY is not set, Animator operates within the user’s original terminal session.

Resolution:

The problem is that when the Animator starts an xterm session, it specifies the foreground and background colors as part of the generated xterm command. This overrides the settings you have for those items in your .Xdefaults file. To solve this problem, you will need to modify the Micro Focus script that invokes xterm, so that it does not specify its own colors during this invocation. Here are steps to accomplish this:

1.  Confirm whether you are running in 32 or 64 bit mode. This is done by executing 'cobmode' at the command prompt:

>cobmode
Effective Default Working Mode: 32 bit

2.  In order to perform the modifications, you will need to be root.

3.  The script that you need to modify will be in the $COBDIR/bin directory.  Based on the results you received from cobmode, you will be editing either cobanim32 or cobanim64.

4.  I recommend first backing up the default cobanimXX file. For example:

cd $COBDIR/bin
cp -p cobanim32 cobanim32_orig

5.  Modify the last line of the cobanimXX file to remove the specification of the foreground and background colors. This is the section you would remove: "-bg black -fg white"

After making the above change, your next debugging session should reflect the color settings from your .Xdefaults file.
Incident #2603198