Created On:  18 August 2010

Problem:

Prior to Hotfix 10 Modernization Workbench did not support extended ASCII characters in SQL statements.

Resolution:

Modernization Workbench 3.1 (From HF10 Onwards) now supports extended ASCII characters (Such as German Umlauts).

This option is switched on from within workspace options (see below):

1.  Open Tools/Workspace Options 
2.  Select Verification/Settings 
3.  Select Cobol File as 'Source Type' if applicable 
4.  Under 'Embedded SQL' Select 'More…' 
5.  Turn the option 'Enable extended ASCII characters in SQL identifiers' on and select 'OK' 
6.  Select PL/I File as Source Type if applicable
7.  Turn the option 'Enable extended ASCII characters in SQL identifieres' to on

Note:  When setting up a new workspace the default option is to NOT allow extended ASCII characters in SQL.  See attached Word document for screenshots of the above setting.
Incident #2457094