Created On:  23 November 2010

Problem:

While installing Modernization Workbench on Windows Server 2008 R2 64 bit, .net 3.5 installation fails with error asking to use Role Management Tool to install.

Resolution:

Go to Microsoft Management Console (from Start/Run/mmc), go into Roles and apply .Net 3.5 that was pre-installed (it just has to be activated). Once the .Net installation is activated and installed then running Setup.exe will do the installs for Licence and MWB.
Incident #2488295