davecal Trusted Contributor.
Trusted Contributor.
1388 views

Error enabling IBS service on shared space

Jump to solution

Im getting the following while trying to enable the intergration bridge.

Oops.

 
Something went wrong.
Please tell us so we can fix it.
Failed to enable Bridge service on selected shared space. Reason: Failed to execute request to http:// servername.company.com:8080/opb/admin/shared_spaces. Message: Service Unavailable. Status code: 503, additional information: <html> <head> <meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1"/>...
 
 
0 Likes
1 Solution

Accepted Solutions
davecal Trusted Contributor.
Trusted Contributor.

Re: Error enabling IBS service on shared space

Jump to solution

Thank you for pointing me in the right direction.

I was missing Hazelcast port. I didn't think it was required as i don't have a clustered environment. 

Thanks

Dave

 

6 Replies
Alexandra Trusted Contributor.
Trusted Contributor.

Re: Error enabling IBS service on shared space

Jump to solution

Hi, 

The info below is not enough to tell the real cause of the issue, but it is probably related to the configurations used during the instalaltion of Sync and IBS.

Do you have Sync, IBS and Octane installed on the same domain and using the same protocol (either http or https)?

Can you access successfully the IBS machine from Octane and Sync, the Sync from IBS and Octane etc? You could try this by running the following WGET commands from your Octane server: wget sync_url/admin/server/version 
wget opb/admin/server/version.

Thanks!
 

 

davecal Trusted Contributor.
Trusted Contributor.

Re: Error enabling IBS service on shared space

Jump to solution

Thank you for your reply.

I get a 503 error from Octane to IBS server

[root@<Octane Server> conf]# wget -v http://<IBS Server>.<Company>.com:8080/opb/
--2018-02-21 03:38:15-- http://<IBS Server>.<Company>.com:8080/opb/
Resolving <IBS Server>.<Company>.com (<IBS Server>.<Company>.com)... 172.**.**.**
Connecting to <IBS Server>.<Company>.com (<IBS Server>.<Company>.com)|172.**.**.**|:8080... connected.
HTTP request sent, awaiting response... 503 Service Unavailable
2018-02-21 03:38:15 ERROR 503: Service Unavailable.

Same results from Octane to Sync

 

IBS to Octane

HTTP request sent, awaiting response... 200 OK
Length: 2175 (2.1K) [text/html]
Saving to: ‘index.html?site’

100%[===================================================================================================================================================================================================>] 2,175

Same results from Sync to Octane

Thanks

 

Dave

0 Likes
Alexandra Trusted Contributor.
Trusted Contributor.

Re: Error enabling IBS service on shared space

Jump to solution

Okay David, so it looks like you have access to IBS and Sync from your Octane machine, which is good, but it seems that IBS was not deployed properly (hence the 503 response).

I guess the issue is in the ibs.yml file you have set for installing IBS, but I cannot tell what the issue is if I don't see the values. You should review all the users, passwords and URLs you have set in there. Maybe it will be easy for you to compare ibs.yml with the sync.yml (they have quite a similar format) and you could notice what is wrong there.

davecal Trusted Contributor.
Trusted Contributor.

Re: Error enabling IBS service on shared space

Jump to solution

Thank you for pointing me in the right direction.

I was missing Hazelcast port. I didn't think it was required as i don't have a clustered environment. 

Thanks

Dave

 

Valued Contributor.. ToanPegasie Valued Contributor..
Valued Contributor..

Re: Error enabling IBS service on shared space

Jump to solution

HI,

We have the same issue,  what did you put for the Hazelcast port? We tried with both empty and 5701, but no luck!

Thanks.

0 Likes
DeyanChavdarov Honored Contributor.
Honored Contributor.

Re: Error enabling IBS service on shared space

Jump to solution

Hi Toan,

Port 5701 should be fine.

I found it useful to set the hazelcast "clusterNodes" parameter to "- localhost" as indicated in the Syncronizer install guide.

Were you able to overcome the issue?

BR,

Deyan

[Give Kudos or accept as Solution, if post helped you :)]
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.