Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..
920 views

Octane CentOS Install Elasticsearch is wrong version

Jump to solution

Is there a way to bypass the Elasticsearch version validation on install? It seems weird Octane would not be backward compatible. 

2018/08/21 18:06:32 | *** Elasticsearch connection check found problems:
2018/08/21 18:06:32 | Elastic search is the wrong version. Hosts:172.17.0.2, Port:9300, Cluster name:docker-cluster, Required version: 5.6.0, Actual version: 6.3.2

0 Likes
1 Solution

Accepted Solutions
Highlighted
Super Contributor.
Super Contributor.

You can do it be adding below line to wrapper.conf file under 'wrapper' folder:

wrapper.java.additional.99=-Ddisable.validator.elasticsearch_connection=true

 

Again - it is highly not recommended. Just install proper version (if possible).

 

Ziv

View solution in original post

4 Replies
Highlighted
Honored Contributor.
Honored Contributor.

Hi Chris,

There's a way to pass the Elasticsearch validation but unfortunately it will not solve your problem. 

Elasticsearch is not backward compatible and it requires a specific version to work properly. 

They introduce many breaking changes with each version and they are not backward compatible. 

Regards,

Idan

Tell us how we can make Octane better!
0 Likes
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Thanks for the response. I have previously installed with this containerized version of ES on a different environment but I do understand. How can I remove the validation from the installation process? 

0 Likes
Highlighted
Super Contributor.
Super Contributor.

You can do it be adding below line to wrapper.conf file under 'wrapper' folder:

wrapper.java.additional.99=-Ddisable.validator.elasticsearch_connection=true

 

Again - it is highly not recommended. Just install proper version (if possible).

 

Ziv

View solution in original post

Highlighted
New Member.

Yes there is a way to bypass the elasticsearch version validation but it's not reliable in terms of privacy and I will not advice you to use it. You must download it through proper channel with proper version validation. You see they are put in the installation process for some reason. However you asked for the way around, here is the way.

wrapper.java.additional.99=-Ddisable.validator.elasticsearch_connection=true

You need to put the above mentioned line under the wrapper folder in the wrapper.conf file.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.