Our vBulletin migration is complete.
Welcome vBulletin users! All content and user information from the Micro Focus Forums (vBulletin) site has been migrated to this site. READ MORE.
NEW_ALM12 Outstanding Contributor.
Outstanding Contributor.
673 views

Unable to launch ALM Octane 12.55 in GUI

Jump to solution

Hi, 

My ALM Octane 12.55 was running perfectly fine till today before I stop and start Octane (HPALM) service. But, once I stop and started the service, its not launching in GUI but the status on server shows as running. Log is as follow:

[root@Octane log]# tail -f /opt/octane/log/wrapper.log
2018/09/06 17:09:36 | jvm 1 | ************************************************************
2018/09/06 17:09:36 | jvm 1 |
2018/09/06 17:09:36 | jvm 1 |
2018/09/06 17:09:36 | jvm 1 |
2018/09/06 17:09:36 | jvm 1 | -------------------------
2018/09/06 17:09:36 | jvm 1 | Starting server setup
2018/09/06 17:09:36 | jvm 1 | -------------------------
2018/09/06 17:09:36 | jvm 1 | Loading octane configuration from /opt/octane/conf/setup.xml
2018/09/06 17:09:36 | jvm 1 | Read setup cluster-wide-sync status (to decide who run CREATE_NEW action) from /opt/octane/repo/storage/site/setup_sync_file.txt
2018/09/06 17:09:36 | jvm 1 | Setup is running on other node, waiting 30 seconds before retrying...

2018/09/06 17:10:06 | jvm 1 | Read setup cluster-wide-sync status (to decide who run CREATE_NEW action) from /opt/octane/repo/storage/site/setup_sync_file.txt
2018/09/06 17:10:06 | jvm 1 | Setup is running on other node, waiting 30 seconds before retrying...
^C
[root@octane log]# service HPALM status
Service HPE ALM Octane is running: PID:5363, Wrapper:STARTED, Java:STARTED


[root@octanelog]# service elasticsearch status
elasticsearch (pid 3984) is running...

 Note: I do not have a cluster environment. 

Any idea how to resolve this?

Im running ALM in RedHat Linu 6.4 version.

0 Likes
1 Solution

Accepted Solutions
NEW_ALM12 Outstanding Contributor.
Outstanding Contributor.

Re: Unable to launch ALM Octane 12.55 in GUI

Jump to solution

Issue has been fixed which started after adding ALM license sharing information in "Octane.yml" file. 

Though the error says about sync.txt file, other node, sync-tool and such, but the actuall issue is unknown. Below steps helped to resolved the issue. 

  1. reverted the changes in octane.yml related to license sharing mode.
  2. backed up storage folder, setup.xml, octane.yml, siteadmin.xml
  3. created new repo folder
  4. created a dummy schema using CREATE_NEW and plain text values for all passwords pointing to a new repo location.
  5. 'setup_sync_file.txt' was recreated.
  6. copied setup_sync_file.txt file into the old repo.
  7. Then, reverted to previous setup.xml file and restarted the service.
  8. This time, the server came up with no problems.
  9. Applied hotfix KM02930624 to apply license sharing mode in octane successfully.

Octane.yml file was modified to set new license mode and there is where the problem started. These kind of files are very sensitive and a combination of modifying it and missing the hotfix on the ALM side caused the reported issue.

 

0 Likes
5 Replies
NEW_ALM12 Outstanding Contributor.
Outstanding Contributor.

Re: Unable to launch ALM Octane 12.55 in GUI

Jump to solution

Im seeig the below error in wrapper.log as well:

2018/09/06 21:22:26 | jvm 1 | com.hp.mqm.infra.common.exceptionhandling.MQMServerException: Error in setup-tool synch: Timeout waiting other node to finish setup

2018/09/06 21:22:26 | jvm 1 | ERROR: Error in setup-tool synch: Timeout waiting other node to finish setup, exception=Error in setup-tool synch: Timeout waiting other node to finish setup

0 Likes
Ziv_Birer Super Contributor.
Super Contributor.

Re: Unable to launch ALM Octane 12.55 in GUI

Jump to solution

Hi,

My name is Ziv Birer and I am from octane R&D.

Please try to delete /opt/octane/repo/storage/site/setup_sync_file.txt and start the service again.

Please let me know if this helps.

If it does not help, please send us entire content of 'log' and 'conf' folder (as ZIP file).

Regards,

Ziv

0 Likes
NEW_ALM12 Outstanding Contributor.
Outstanding Contributor.

Re: Unable to launch ALM Octane 12.55 in GUI

Jump to solution
Hi,
I deleted that txt file couple of time and started the service. But still the same issue.
I have attached logs(wrapper.log, siteadmin, setup, octane.yml) file in my original post. Please see attached in original post above and let me know if I need to submit again.
Thank you.
0 Likes
NEW_ALM12 Outstanding Contributor.
Outstanding Contributor.

Re: Unable to launch ALM Octane 12.55 in GUI

Jump to solution

Issue has been fixed which started after adding ALM license sharing information in "Octane.yml" file. 

Though the error says about sync.txt file, other node, sync-tool and such, but the actuall issue is unknown. Below steps helped to resolved the issue. 

  1. reverted the changes in octane.yml related to license sharing mode.
  2. backed up storage folder, setup.xml, octane.yml, siteadmin.xml
  3. created new repo folder
  4. created a dummy schema using CREATE_NEW and plain text values for all passwords pointing to a new repo location.
  5. 'setup_sync_file.txt' was recreated.
  6. copied setup_sync_file.txt file into the old repo.
  7. Then, reverted to previous setup.xml file and restarted the service.
  8. This time, the server came up with no problems.
  9. Applied hotfix KM02930624 to apply license sharing mode in octane successfully.

Octane.yml file was modified to set new license mode and there is where the problem started. These kind of files are very sensitive and a combination of modifying it and missing the hotfix on the ALM side caused the reported issue.

 

0 Likes
Highlighted
Ziv_Birer Super Contributor.
Super Contributor.

Re: Unable to launch ALM Octane 12.55 in GUI

Jump to solution

Good to know, thanks for the update.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.