New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Highlighted
Absent Member.. Absent Member..
Absent Member..
7642 views

ALM 11, patch 7 : User connection error in Quality center

Hi,

 

I've just patched my Quality center ALM with patch 07.

Now i'm facing some troubles, each time a user wants to authenticate, it fails.

I've found this error in log files:

 

com.mercury.optane.core.CTdException

Messages:
Failed to Login;
OTA version not compatible with server. Site version: 11 build number: 6051;

Stack Trace:
com.mercury.optane.core.CTdException: OTA version not compatible with server. Site version: 11 build number: 6051
at com.mercury.td.tdserver.requests.Login.execute(Login.java:83)

 

it seams like there's a difference between client and server OTA. On the client i've deleted the HP repository, so that it download the latest version at first connection.

 

In the Admin console, i've checked the license, and i've found another error (after patch) it desapeared.

My license is just gone, and when i want to import it or refresh it , i got an error: see attachements (Syntax error in line #1...

 

Does anyone had some troubles after patching HP ALM11?

 

The only option i see for now is re-installing HP ALM

 

 

 

0 Likes
6 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Patch 7 (in fact, most patches) include a new version of the OTA client. Any system where you have run the HP ALM Client Registration process (from the Add-ins page) will need to have this done again. Same is true if you built an MSI to deploy the client files to you client systems. This registration would have been needed on any workstation that was running any of the Add-ins, like the Excel Add-in, the Word Add-in, etc. That should resolve the authentication problem.

Regarding the License problem, I have no clue. I think you need to contact HP support on that.
[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

I have the same error when I try to use the excel Add IN : "OTA version is not compatible with the ALM server: http://server:port/qcbin/wcomsrv.dll. OTA version: 11, OTA build number:4804. Server version: 11, server build number: 7051".

This message appears when I click on Next button, after having entered my user name and user password.

 

When I see the version on QC, the OTA client build is 7051. (all the other components have the same version)

I followed the instructions of the Add-in guide to install Add-in Excel.

I use Microsoft Excel 2010 (version 14.0.6112.5000(32 bit)).

The version of the HP ALM Export Wizard is V.11.0.0.36 ...

 

I don't understand ...

 

Thanks for your help

0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Jeff,

 

before installing the new patch, you need to uninstall all the existing patches of QC and then you can install the Patch 7.

Regarding you error! Reinstall the ALM again, and please pay attention to the read me file. It deals with an error. For detail, see the Loader file, it occurs while installing it on the client side.

This problem is caused by the VeriSign, and it is somthing HP doen not have control.

The error is caused by a change in the way VeriSign carry out the client certification. The solution to the problem is also available in the read me file.

I will suggest you to upgrade directly to Patch 8 of ALM.

Please check the Upgrade guide and the Recommended Systemrequirements, may be you can get a clue to your issue.

 

Hopefully it helps!

 

Best regards,

Bharti

 

 

0 Likes
Highlighted
Cadet 3rd Class
Cadet 3rd Class

Hi,

 

i have had the same error on some clients after updating the server to QC 11 to SP 3. The solution on this clients was to delete the folder:

 

c:\users\<userid>\AppData\Local\HP

 

After deleting this directory the client was successfully installed.

0 Likes
Highlighted
Absent Member.
Absent Member.

Hi,

I have got the same issue since I use ALM 11 patch 12. I have two other versions 11 patch 9 and QC 10 running in parallell and the code used to work with both emvironments.

 

I have deleted the folder but that did not change anything. 

I have also uninstalled the Excel plug-in and re-installed it.

 

Any more suggestions?

 

Bernhard

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

You will still need to update the client by connecting to that newly patched system.  I also had to restart the client machine. 

 

Most likely that client won't work with your differently patched systems once it is upgraded to the new OTA version.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.