Absent Member.
Absent Member.
1690 views

Authentication failure when trying to connect HP ALM server

Hi, 

 

I get an authentication failure when trying to connect HP ALM server "http://myserver:port/qcbin" via third party tool. 

 

I should propmted to log in with my login name and password, but I do not see the message box.

 

I also tried "http://myserver:port/qcbin/rest/is-authenticated" and entered my username and password, but it gives me "401 - Unauthorized: Access is denied due to invalid credentials.”  

 

Please I need your help asap.

 

P.S.: I can enter HP ALM application (http://myserver:port/qcbin) with my username and password. 

 

Thanks in advance!

 
0 Likes
7 Replies
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

It would help to know what the third part tool is.

 

Version of ALM

 

Browser and Windows version you are using.

 

If you can log in directly to ALM normally.


~Have you Read The Felicitous Manual?
~Please hit the KUDOS button if my reply helped resolve your issue.
0 Likes
Absent Member.
Absent Member.

third part tool: Rational Adapter for HP ALM 1.1

 

Version of ALM: HP ALM 11

 

Browser and Windows version you are using: Internet explorer and also tried with chrome in Windows 7

 

0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

ALM 11 is not compatible with Chrome.

 

What version of IE are you using?

 

Have you been able to successfully log in to JUST ALM on this computer before?


~Have you Read The Felicitous Manual?
~Please hit the KUDOS button if my reply helped resolve your issue.
0 Likes
Absent Member.
Absent Member.

IE version 9.

 

Yes, I use HP ALM with internet explorer everyday.

0 Likes
Absent Member.
Absent Member.

I solved "...rest/is-authenticated" and got an xml response with my authentication info, but in the Rational adapter, I still get same authentication error whenever I try to connect to the server ???

0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Given that this is Rational failing to connect, have you tried IBM support or forums?


~Have you Read The Felicitous Manual?
~Please hit the KUDOS button if my reply helped resolve your issue.
0 Likes
Absent Member.
Absent Member.

I will try also IBM forums. But last question, I only get user name with XML authenticationInfo. Should not I get also password ? or only username is correct ?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.