New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Highlighted
Absent Member.
Absent Member.
606 views

Error importing requirements from Excel - Parent not found?

Hello.

 

I am trying to import some requirements in ALM 11.52 via Excel. I have requirement types in a folder, and able to create folders, and other requirement types just fine as part of the export.

 

There is a need, however, to have parent-child relationship between requirements without involving folders. A buiness requirement, for example, might be covered by 5 functional requirements so I am trying to have 5 functional requirements appear under 1 business requirement as part of the export.

 

When I provide "path" (like below) for the 5 functional requirements (to appear under 1 business requirement), ALM throws error (-3) saying parent not found when parent path and the parent Business Requirement are there. In QC 10 we were able to import requirements using this parent-child relationship between requirements without involving folders but in ALM this is not working .. maybe I am doing something wrong?

 

Here is the path I am using for 5 functional requirements, and these folders are already there as well as the BusinessRequirement1:

 

Parent Folder\Child Folder\BusinessRequirement1

 

Any help is greatly appreciated.

 

Thanks!

0 Likes
2 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Are you able to create the child requirements manually?  Try that to confirm that the relationship is allowed. If it can be done manually, you should be able to import that heirarchy.

 

In other threads where the same error was reported, users found that they had leading or trailing blank spaces in the path specification in Excel. Make sure you don't have any leading or trailing blank spaces in your data.

[If this post solves or helps solve your issue, mark the thread as solved and give KUDOS to the author for their assistance.]

(Opinions expressed in my postings are mine alone, and do not reflect the opinions of my employer.No warranties express or implied for any solution/suggestion posted.)
0 Likes
Highlighted
Cadet 3rd Class Cadet 3rd Class
Cadet 3rd Class

I faced the exact similar issue Yesterday. After some R&D, I realized cell format that is on 'Business' requirement row causing issue. So I deleted the cells on that row and re-formated. Then it worked fine. You may try the same way. Or provide the excel sheet, I will let you know where the issue is.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.