Highlighted
Absent Member.
Absent Member.
7288 views

Excel Addin problem as "Invalid access to memory lcoation"

When I click 'Export to Quality Center' button, I receive the error as "A general error has occurred. Restart Microsoft Excel. 'Automation error Invalid access to memory location.'"

We have problem about Excel Add-in tool with windows 7 OS(32bit and 64bit versions are in use) and excel 2010.

We are using QC 9.2 and its' Excel Add-in tool which I downloaded recently via the http://update.external.hp.com/qualitycenter/qc90/msoffice/msexcel/index.html link.

Any information any suggest would be much appreciated.

Thanks,
Aylin
0 Likes
6 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Hi Aylin,
I would say, ask HP support (open a service case). I can remember that I get a Patch in the past for an other problem with Excel. Therefore, they must have a Patch for such errors.

Kind regards,
A.E.
0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Erodabasi,
Thanks for your suggestions.
Actually, Excel Addin for QC 9.2 is not supported for Excel 2010 version.
But from our experiements, Excel Addin works with excel2010 on windowsXP.

Our problem started to occur when we passed to windows7.

Regards, Aylin
0 Likes
Highlighted
Absent Member.
Absent Member.

The QC 9.2 Excel Addin Works fine with 2010(Actually supported) If you are getting error "Excel Addin problem as "Invalid access to memory location" or "object variable not set"then perform the following steps:

 

Un Install the excel addin.

Delete the XLSTART folder "C:\Program Files\Microsoft Office\Office14" or(Office 12)

Open the excel .

Go to file and click on options

Click on Trust Center on the "left navigation" and "Click on Trust Center Settings" in the right

Click on trusted Locations in the left navigation and delete any trusted path like "C:\Program Files\Microsoft Office\Office14" or(Office 12)\xlstart" in the right

Install the Addin again and you are good to go.

 

I hope this will help everyone.

 

Thanks,

Gaurav Rathi

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

I am having this same problem. I tried the steps outlined here and am still having the same problem.  Any help would be greatly appreciated.

 

Thanks,

 

Barry Alkis

0 Likes
Highlighted
Absent Member.
Absent Member.


RESOLVED :
I after lot of efforts I found outthe solution-

 

1. Open MS Excel 2010

2. Navigate to  Option--> Trus Center -->Trus Center Settings --> Protected View --> Uncheck the Enable Data Execution

Prevention Mode

3. Restart the Excel and check.


Cheers !

Highlighted
Absent Member.
Absent Member.

Thank you, It is working fine

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.