UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Absent Member.
Absent Member.
1181 views

QC auto email

Hi

I am using QC 11.00. I want to  sent Auto email to Assign to and Defected by when a new defect is opened but when I click Tools>>Customize>> Automail I get the message "A field bg_responsible does not exist in the project "

please need help

0 Likes
9 Replies
Absent Member.
Absent Member.

Hi,

 

I'm not sure, but it can be related to server/db_sever/client locale

 

Can you reproduse this issue on new project?

0 Likes
Absent Member.. Absent Member..
Absent Member..

Have you somehow removed this field from the Defect Details?  This is the Assigned To field.

0 Likes
Absent Member.
Absent Member.

Hi thanks for reply

No I don't removed any defect details.There is a screen shot. But I get these message When I select user like screen shot 

0 Likes
Absent Member.
Absent Member.

hi Thanks for reply

 yes I can reporoduce on new project ı dont understand why get these message and why cant get email.

 

0 Likes
Absent Member.
Absent Member.

Please try to reproduce this issue on projects using different DB (Oracle and MS SQL)

0 Likes
Absent Member.. Absent Member..
Absent Member..

Was this project created using a Template Project? I see the Assigned To field on the defect screenshot you gave, but this may be a user defined field which is simply labled Assigned To and your project really isn't using the original system field for Assigned To. If this was done in the Template Project, then it is passed down to all projects created from this Template Project.

Have you verified the Workflow code to ensure that this field is not being deactivated somehow through the code?

Can you view the logs for more detailed error information?
0 Likes
Absent Member.
Absent Member.

hi

there is a screen shot of Defect Details Field Customization could you pleasa help me  is there something wrong 

and in script editor the code is

 

Function Bug_CanPost
  On Error Resume Next

  Bug_CanPost = DefaultRes
  On Error GoTo 0
End Function

 

Function Bug_CanDelete(Entity)
  On Error Resume Next

  Bug_CanDelete = DefaultRes
  On Error GoTo 0
End Function

 

Sub Bug_AfterPost
  On Error Resume Next

  On Error GoTo 0
End Sub

0 Likes
Absent Member.
Absent Member.

Hi thanks for reply

I can now sent mail to Assign to but my problem still continue After customization QC delets all userList as seen in screen shot.  and gives message "A field named bg_responsible does not exist in the project"

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.