New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Highlighted
Absent Member.
Absent Member.
437 views

QTP can not 'find' link

Jump to solution
I have a workflow script which captures dynamically created id information and performs multiple actions on that new id. When I run the script, the first time the script accesses that action link, it can not recognize it. When the script gets past this point, it recognizes the action link. I've run maint. mode and update, nothing works. Anyone have any suggestions?

I'm going nuts. Thanks in advance.
0 Likes
27 Replies
Highlighted
Absent Member.
Absent Member.
Hmmm, I want to get the dynamically created appl_id before the 'concur' step and be able to update the properties of the 'concur' action link.
0 Likes
Highlighted
Absent Member.
Absent Member.
Here is the use of SetTOProperty.

object.SetTOProperty ,

Here as you have told property name is "href" and pass the value of the property at runtime.

Please ensure that href property is not already added to the object.

Thanks..
Arpan

View solution in original post

Highlighted
Absent Member.. Absent Member..
Absent Member..
Hi CFonseca,
I see one of your attachment a can say that you have many problems.

At first you have to prepare your object in object repository when you have dynamical values:
Before you record all the steps
- new test
- record only one step
- goto object repository
- select the WebPage Object "GrantSolution" (there will be only one when you record only one step) and insert a regular expression (choose a value that wouldn't change) for the relevant value on the right side.
- If necessary do this by BrowserObject too!
Do this by all other objects when you see in ExpertView something like "String_" (e.g. GrantSolution_52, GrantSolution_53, ...)

Then you can record your test complete

If QTP says "Object matches more the one ..." then go in object repository to the object (in your case to the link object) and select on the right side by Ordinal identifier "index" an type 0 as value

You should although configure your Object Identification too.


0 Likes
Highlighted
Absent Member.
Absent Member.
Sorry, the last solution did not result in my script running. Not sure how the first part of the solution relates to my problem. Explain?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.