Highlighted
Respected Contributor.
Respected Contributor.
483 views

Supported Oracle version in ALM Version 12.50 Patch 1

Jump to solution

Good morning,

I was reading the tech specs for version 12.50 patch 1 of ALM.  We will need to upgrade from version 12.20 to 12.50 patch 1 soon, to support Windows 10.

At this time, our Oracle version is at 11.2.04.  And they will not be upgrading to 12 at this time.

My question is, is ALM 12.50 Patch 1 backward compatible to Oracle 11.2.04 even tho on the tech spec sheet it states Oracle 12?  

 

Thank you very much,

 

Penny Wall

1 Solution

Accepted Solutions
Highlighted
Absent Member.
Absent Member.

Hello Jan,

The information was provided according the official system requirements page:

https://hpln.hpe.com/product/alm/pages/3376

 

Databases

Oracle 12c

Microsoft SQL Server 2012

Microsoft SQL Server 2014

 

In addition as you know you will have to install ALM 12.50 first and then install the patch

Please see what the patch readme states

 System Requirements

This section includes recommended and supported environments for HP ALM 12.x

Important: The supported environment information is accurate for the HP ALM 12.x release, but there may be updates for HP ALM 12.x patches. For the most up-to-date system requirements and supported environments information, see ALM System requirements

 

ALM 12.50 with the patch 1 will support this:

 12.50.png

Regards,

Sue Sevilla | SW Technical Support Consultant.

Application Lifecycle Management

Hewlett-Packard

 

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.

If you are satisfied with anyone's response please remember to give them KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation."

 

 

View solution in original post

0 Likes
5 Replies
Highlighted
Absent Member.
Absent Member.

Hello Penny,

 

As you know that oracle version is not supported with ALM 12.50 patch 1

So if you install ALM 12.50 with that version you will get an error message that DB is not supported however you can disable the validation check. For more

Information, refer to "Disabling Validation Checks for the Installation Wizard" ALM installation guide.

Just take in mind that even with that workaround you will have a non-supported environment

 

Regards,

Sue Sevilla | SW Technical Support Consultant.

Application Lifecycle Management

Hewlett-Packard

 

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.

If you are satisfied with anyone's response please remember to give them KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation."

 

 

0 Likes
Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..

Dears,

Sue Sevilla,

Re :


As you know that oracle version is not supported with ALM 12.50 patch 1


I see in document "HP_ALM_12_50_Patch_01_Realese_Notes.doc" in the section "System Requirements", subsection "Supported ALM Server-Side Configuration"  Oracle 11.2.0.4 listed as recommended database server !?

Is that to be considered as erroneous information then ?

Best regards,

Jan

 

0 Likes
Highlighted
Absent Member.
Absent Member.

Hello Jan,

The information was provided according the official system requirements page:

https://hpln.hpe.com/product/alm/pages/3376

 

Databases

Oracle 12c

Microsoft SQL Server 2012

Microsoft SQL Server 2014

 

In addition as you know you will have to install ALM 12.50 first and then install the patch

Please see what the patch readme states

 System Requirements

This section includes recommended and supported environments for HP ALM 12.x

Important: The supported environment information is accurate for the HP ALM 12.x release, but there may be updates for HP ALM 12.x patches. For the most up-to-date system requirements and supported environments information, see ALM System requirements

 

ALM 12.50 with the patch 1 will support this:

 12.50.png

Regards,

Sue Sevilla | SW Technical Support Consultant.

Application Lifecycle Management

Hewlett-Packard

 

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.

If you are satisfied with anyone's response please remember to give them KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation."

 

 

View solution in original post

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Thanks Jan and Sue for your comments.  I am glad to hear that 12.50 patch 1 supports Oracle 11.2.0.4 as well as Oracle 12!

 

Thank you very much!

 

Penny

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

ALM Version 12.50 Patch 1 seems to be the same download size as ALM Version 12.50. 

Does this mean we can just install the ALM Version 12.50 Patch 1... or do we have to install ALM Version 12.50 first?

If the answer is we must install ALM Version 12.50 first, then how could this ever work with an upgrade?  If ALM Version 12.50 cannot talk to Oracle 11.2.0.x then you cannot install it.  So you would never be able to upgrade.

This also affects customers who are on ALM 11.52 as it only support Oracle 11.2.0.x.  If they want to upgrade to ALM 12.50 and it only support Oracle 12c... how would they ever be able to upgrade?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.