Absent Member.
Absent Member.

Unable to Identify data/text under Java SWT eclipse browser

Our application is developed with the Java which is using embedded eclipse browser( AUT is a JAVA application based on Eclipse. So , it's an SWT GUI). QTP identifies the entire page as a JavaObject. But it is not identifying any objects inside this eclipse browser.

Currently we are using QTP 10 and Java addin. We tried lot methods to resolve this issue by changing the QTP-Java/Web settings and We have also upgraded by instaliing the "Java Extensibility SDK" but still the problem is not resolved. Please let me know whether you have faced such kind of issue earlier , if yes , what would be the correct solution to over come this problem .

Please find the attached screenshot of issue and let me know if you need any more info from my side. As this issue is high priority one which is preventing us to autoamate complete appln so please spare some of your time and provide us exact solution.
3 Replies
Absent Member.
Absent Member.

Following Methods are tried to make QTP recognize the my data under eclipse browser report :-

1) I tried to registering it as a Browser object:-

Start > Programs > QuickTest Professional > Tools > Register New Browser Control

2) Added the below lines to mic.ini file located here:-

C:\Program Files\HP\QuickTest Professional\bin.

below the [ie_hook] section.

3) Deselected the Java Addin and selected only Web Addin.

4) I tried invoking the application by QTP Run and Record setting but QTP failed to recognize the objects (Go to Automation -> Record and Run Settings -> Java -> Open the following application when a record or run session begins -> Executable File Set to C:\BTFrame_2010_12_23_Buil210\BTFrame.exe)

5)I selected all the options under File -> Settings -> Java.

6)I tried altering the settings under Tools -> Options -> Java -> Advance but still QTP didn't recognize the objects.

7) I Copied jvmhook.dll file from C:\Program Files\HP\QuickTest Professional\bin\java_shared\bin to C:\BTFrame_2010_12_23_Buil210\jre\bin

😎 I tried altering the Environment variable (Start -> Control Panel -> System -> Advanced -> Environment Variables -> System Variables -> PATH) _JAVA_OPTIONS and JAVA_TOOL_OPTIONS as well.

_JAVA_OPTIONS = -Xrunjvmhook -Xbootclasspath/a:C:\PROGRA~1\HP\QUICKT~1\bin\JAVA_S~1\classes;C:\PROGRA~1\HP\QUICKT~1\bin\JAVA_S~1\classes\jasmine.jar
IBM_JAVA_OPTIONS = -Xrunjvmhook -Xbootclasspath/a:C:\PROGRA~1\HP\QUICKT~1\bin\JAVA_S~1\classes;C:\PROGRA~1\HP\QUICKT~1\bin\JAVA_S~1\classes\jasmine.jar
JAVA_TOOL_OPTIONS = -agentlib:jvmhook
_classload_hook = jvmhook

9) In Command promprt checked the java version (C:\>java -version) ,and same compared with the control panel-> system-> environment variable values.

C:\>java -version
Picked up JAVA_TOOL_OPTIONS: -agentlib:jvmhook
Picked up _JAVA_OPTIONS: -Xrunjvmhook -Xbootclasspath/a:C:\PROGRA~1\HP\QUICKT~1\
java version "1.6.0_18"
Java(TM) SE Runtime Environment (build 1.6.0_18-b07)
Java HotSpot(TM) Client VM (build 16.0-b13, mixed mode)

10) I Tried in the following method also.

Start > Run - type regedit

In MyComputer > HKEY_LOCAL_MACHINE > SOFTWARE > Mercury Interactive > Java Agent > Java-Add in for QuickTest folder.

Check in right side window for Enabled file. right click on that file and select Modify.

Check Value data is 1 and Hexadeciaml radio button is selected

11) My application make use of SWT Nebulla Widgets and QTP is only identifying a Java Object but not all the objects within Class "SWT_Window".

To solve this issue I tried to use SWT extensibility option of QTP 10.
There are some built in extension files in installation path of QTP i.e. c:\Program Files\HP\QuickTest Professional\bin\java\classes\builtin

I copied those files to c:\Program Files\HP\QuickTest Professional\bin\java\classes\extension.

NOW I can see this extension(SWT) on starting QTP 10 when add inn window appears on start up, However SWT objects are not getting identified, neither Object Identification option in Tools showing any Test Object classes for SWT.

I can see all these classes are lying there in mic.jar which is common for all the addins.

12) QC/QTP 10.0 - Java extensibility plug-in installed but not recognized

Still unable to identify the JAVA SWT HTML report and still finding exact solution to make QTP recognized the same. Hope you would provide me exact solution for this issue.
Absent Member.. Absent Member..
Absent Member..

Make following settings and you are good to go:

Control Panel > Java > Advance tab > Java Plug-in > Uncheck (Enable the next-generation Java Plug-in Checkbox)

Absent Member.
Absent Member.


I cant see java plugin under Advaned Tab in java,


Please help I am also not able to automate swt ellipse browser , entire window is considered as Java Object Browser 

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.