Highlighted
garima_aggarwal Absent Member.
Absent Member.
1272 views

CFilter AgRegexAuto No extension Matched the Uri


Hi

I am trying to access and consume the Identity manager Services from User Application. (Using Protected Resources).

I am hitting following URL from UA

https://abc.com/nps/servlet/frameservice?NPService=fw.LaunchService&NPAction=Launch&launch=base.DisableAccount&launcher=fw.LaunchService&lifecycle=Recreate&repeatable=false&targetNames=a5@abc\.com.AUS011316.INT002442.CUSTOMERS.USERS.ti

I am getting 500 Internal Server Error in response.

On checking the error_log on AG side, i can see the following things coming up in logs


2017-02-10T14:44:58.831797+08:00 vhhtsusidm91 httpd[22411]: [debug] ../AGFilterPolicy.cpp(27): AMEVENTID#3488: CFilter AgFilterPolicy Initialized, referer:
2017-02-10T14:44:58.831882+08:00 vhhtsusidm91 httpd[22411]: [debug] ../AGRegexAutoFilter.cpp(31): AMEVENTID#3488: CFilter AgRegexAuto Compare Initialized, referer:
2017-02-10T14:44:58.831967+08:00 vhhtsusidm91 httpd[22411]: [debug] ../AGRegexAutoFilter.cpp(42): AMEVENTID#3488: CFilter AgRegexAuto No extension Matched the Uri, referer:
2017-02-10T14:44:58.832051+08:00 vhhtsusidm91 httpd[22411]: [debug] ../AGFilterPolicy.cpp(33): AMEVENTID#3488: CFilter AgFilterPolicy match returned false, referer:
2017-02-10T14:44:58.832160+08:00 vhhtsusidm91 httpd[22411]: [debug] ../AGFilterPolicy.cpp(38): AMEVENTID#3488: CFilter AgFilterPolicy no match found, referer:

It seems, AG is not able to find /nps path in protected resources, but this is available in protected resources. I have other protected resources configured as well and all are working fine.

Does anybody know, how we can fix this issue.

Thanks.

0 Likes
8 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: CFilter AgRegexAuto No extension Matched the Uri

On 2/10/2017 7:56 PM, garima aggarwal wrote:
>
> Hi
>
> I am trying to access and consume the Identity manager Services from
> User Application. (Using Protected Resources).
>
> I am hitting following URL from UA
>
> -https://abc.com/nps/servlet/frameservice?NPService=fw.LaunchService&NPAction=Launch&launch=base.DisableAccount&launcher=fw.LaunchService&lifecycle=Recreate&repeatable=false&targetNames=a5@abc\.com.AUS011316.INT002442.CUSTOMERS.USERS.ti-
>
> I am getting *500 Internal Server Error* in response.
>
> On checking the error_log on AG side, i can see the following things
> coming up in logs
>
>
> 2017-02-10T14:44:58.831797+08:00 vhhtsusidm91 httpd[22411]: [debug]
> ../AGFilterPolicy.cpp(27): AMEVENTID#3488: CFilter AgFilterPolicy
> Initialized, referer:
> 2017-02-10T14:44:58.831882+08:00 vhhtsusidm91 httpd[22411]: [debug]
> ../AGRegexAutoFilter.cpp(31): AMEVENTID#3488: CFilter AgRegexAuto
> Compare Initialized, referer:
> 2017-02-10T14:44:58.831967+08:00 vhhtsusidm91 httpd[22411]: [debug]
> ../AGRegexAutoFilter.cpp(42): AMEVENTID#3488: CFilter AgRegexAuto No
> extension Matched the Uri, referer:
> 2017-02-10T14:44:58.832051+08:00 vhhtsusidm91 httpd[22411]: [debug]
> ../AGFilterPolicy.cpp(33): AMEVENTID#3488: CFilter AgFilterPolicy match
> returned false, referer:
> 2017-02-10T14:44:58.832160+08:00 vhhtsusidm91 httpd[22411]: [debug]
> ../AGFilterPolicy.cpp(38): AMEVENTID#3488: CFilter AgFilterPolicy no
> match found, referer:
>
> It seems, AG is not able to find /nps path in protected resources, but
> this is available in protected resources. I have other protected
> resources configured as well and all are working fine.
>
> Does anybody know, how we can fix this issue.
>
> Thanks.
>
>


Sorry, i have no clue what functionality you are referring to here to be
honest. Is there any link in the userapp documentation about this?

--
Cheers,
Edward
0 Likes
garima_aggarwal Absent Member.
Absent Member.

Re: CFilter AgRegexAuto No extension Matched the Uri

edmaa;2450701 wrote:
On 2/10/2017 7:56 PM, garima aggarwal wrote:
>
> Hi
>
> I am trying to access and consume the Identity manager Services from
> User Application. (Using Protected Resources).
>
> I am hitting following URL from UA
>
> -https://abc.com/nps/servlet/frameservice?NPService=fw.LaunchService&NPAction=Launch&launch=base.DisableAccount&launcher=fw.LaunchService&lifecycle=Recreate&repeatable=false&targetNames=a5@abc\.com.AUS011316.INT002442.CUSTOMERS.USERS.ti-
>
> I am getting *500 Internal Server Error* in response.
>
> On checking the error_log on AG side, i can see the following things
> coming up in logs
>
>
> 2017-02-10T14:44:58.831797+08:00 vhhtsusidm91 httpd[22411]: [debug]
> ../AGFilterPolicy.cpp(27): AMEVENTID#3488: CFilter AgFilterPolicy
> Initialized, referer:
> 2017-02-10T14:44:58.831882+08:00 vhhtsusidm91 httpd[22411]: [debug]
> ../AGRegexAutoFilter.cpp(31): AMEVENTID#3488: CFilter AgRegexAuto
> Compare Initialized, referer:
> 2017-02-10T14:44:58.831967+08:00 vhhtsusidm91 httpd[22411]: [debug]
> ../AGRegexAutoFilter.cpp(42): AMEVENTID#3488: CFilter AgRegexAuto No
> extension Matched the Uri, referer:
> 2017-02-10T14:44:58.832051+08:00 vhhtsusidm91 httpd[22411]: [debug]
> ../AGFilterPolicy.cpp(33): AMEVENTID#3488: CFilter AgFilterPolicy match
> returned false, referer:
> 2017-02-10T14:44:58.832160+08:00 vhhtsusidm91 httpd[22411]: [debug]
> ../AGFilterPolicy.cpp(38): AMEVENTID#3488: CFilter AgFilterPolicy no
> match found, referer:
>
> It seems, AG is not able to find /nps path in protected resources, but
> this is available in protected resources. I have other protected
> resources configured as well and all are working fine.
>
> Does anybody know, how we can fix this issue.
>
> Thanks.
>
>


Sorry, i have no clue what functionality you are referring to here to be
honest. Is there any link in the userapp documentation about this?

--
Cheers,
Edward



Hi

I am able to figure out the issue, this is because of SSL handshake failing.

2017-02-10T18:02:23.457029+08:00 vhhtsusidm92 httpd[13811]: [debug] ssl_engine_kernel.c(1911): OpenSSL: Loop: SSLv3 read server hello A
2017-02-10T18:02:23.457093+08:00 vhhtsusidm92 httpd[13811]: [debug] ssl_engine_kernel.c(1333): Certificate Verification: depth: 1, subject: /OU=Organizational CA/O=IPSA-TREE, issuer: /OU=Organizational CA/O=IPSA-TREE
2017-02-10T18:02:23.457213+08:00 vhhtsusidm92 httpd[13811]: [error] Certificate Verification: Error (19): self signed certificate in certificate chain
2017-02-10T18:02:23.457476+08:00 vhhtsusidm92 httpd[13811]: [debug] ssl_engine_kernel.c(1921): OpenSSL: Write: SSLv3 read server certificate B
2017-02-10T18:02:23.457539+08:00 vhhtsusidm92 httpd[13811]: [debug] ssl_engine_kernel.c(1940): OpenSSL: Exit: error in error
2017-02-10T18:02:23.457602+08:00 vhhtsusidm92 httpd[13811]: [debug] ssl_engine_kernel.c(1940): OpenSSL: Exit: error in error
2017-02-10T18:02:23.457654+08:00 vhhtsusidm92 httpd[13811]: [info] SSL Proxy connect failed
2017-02-10T18:02:23.457878+08:00 vhhtsusidm92 httpd[13811]: [info] SSL Library Error: 336134278 error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
2017-02-10T18:02:23.458100+08:00 vhhtsusidm92 httpd[13811]: [info] Connection closed to child 0 with abortive shutdown (server abc.com:443)
2017-02-10T18:02:23.458336+08:00 vhhtsusidm92 httpd[13811]: [error] (502)Unknown error 502: proxy: pass request body failed to 192.168.87.40:8443 (192.168.87.40)
2017-02-10T18:02:23.458560+08:00 vhhtsusidm92 httpd[13811]: [error] AMEVENTID#12395: proxy: Error during SSL Handshake with remote server returned by /nps/, referer: https://abc.com/nesp/idff/spassertion_consumer?SAMLart=AAPWQtihBFK0vTtR2a1e%2BMq8tAjFNc67i60uDgzKz897ZRZNJOFm7Ny1&RelayState=MA%3D%3D
2017-02-10T18:02:23.458778+08:00 vhhtsusidm92 httpd[13811]: [error] AMEVENTID#12395: proxy: pass request body failed to 192.168.87.40:8443 (192.168.87.40) from 192.168.29.2 (), referer: https://abc.com/nesp/idff/spassertion_consumer?SAMLart=AAPWQtihBFK0vTtR2a1e%2BMq8tAjFNc67i60uDgzKz897ZRZNJOFm7Ny1&RelayState=MA%3D%3D
2017-02-10T18:02:23.458999+08:00 vhhtsusidm92 httpd[13811]: [debug] proxy_util.c(2066): proxy: HTTPS: has released connection for (192.168.87.40)


Each and every certificate are in place. However, am still getting this error.
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: CFilter AgRegexAuto No extension Matched the Uri

On 2/10/2017 10:36 PM, garima aggarwal wrote:
>


> Each and every certificate are in place. However, am still getting this
> error.
>
>


As a test, on the webserver tab under your proxy configuration, can you
set the 'Web Server Trusted Root' to 'Do not verify' and see if it then
works?

--
Cheers,
Edward
0 Likes
garima_aggarwal Absent Member.
Absent Member.

Re: CFilter AgRegexAuto No extension Matched the Uri

edmaa;2450779 wrote:
On 2/10/2017 10:36 PM, garima aggarwal wrote:
>


> Each and every certificate are in place. However, am still getting this
> error.
>
>


As a test, on the webserver tab under your proxy configuration, can you
set the 'Web Server Trusted Root' to 'Do not verify' and see if it then
works?

--
Cheers,
Edward


Hi Edward

I tried the configs you suggested.

Now am not getting SSL handshake error. It showing a blank page for me.

Am getting following in error_log

2017-02-12T17:15:50.274801+08:00 vhhtsusidm92 httpd[15306]: [debug] ../AGFilterPolicy.cpp(27): AMEVENTID#159263: CFilter AgFilterPolicy Initialized, referer: https://abc.com/nps/
2017-02-12T17:15:50.274882+08:00 vhhtsusidm92 httpd[15306]: [debug] ../AGRegexAutoFilter.cpp(31): AMEVENTID#159263: CFilter AgRegexAuto Compare Initialized, referer: https://abc.com/nps/
2017-02-12T17:15:50.274954+08:00 vhhtsusidm92 httpd[15306]: [debug] ../AGRegexAutoFilter.cpp(42): AMEVENTID#159263: CFilter AgRegexAuto No extension Matched the Uri, referer: https://abc.com/nps/
2017-02-12T17:15:50.275048+08:00 vhhtsusidm92 httpd[15306]: [debug] ../AGFilterPolicy.cpp(33): AMEVENTID#159263: CFilter AgFilterPolicy match returned false, referer: https://abc.com/nps/
2017-02-12T17:15:50.275141+08:00 vhhtsusidm92 httpd[15306]: [debug] ../AGFilterPolicy.cpp(38): AMEVENTID#159263: CFilter AgFilterPolicy no match found, referer: https://abc.com/nps/

--Dinesh

0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: CFilter AgRegexAuto No extension Matched the Uri

On 2/12/2017 8:36 PM, garima aggarwal wrote:
>


> Now am not getting SSL handshake error. It showing a blank page for me.
>
> Am getting following in error_log
>
> 2017-02-12T17:15:50.274801+08:00 vhhtsusidm92 httpd[15306]: [debug]
> ../AGFilterPolicy.cpp(27): AMEVENTID#159263: CFilter AgFilterPolicy
> Initialized, referer: https://abc.com/nps/
> 2017-02-12T17:15:50.274882+08:00 vhhtsusidm92 httpd[15306]: [debug]
> ../AGRegexAutoFilter.cpp(31): AMEVENTID#159263: CFilter AgRegexAuto
> Compare Initialized, referer: https://abc.com/nps/
> 2017-02-12T17:15:50.274954+08:00 vhhtsusidm92 httpd[15306]: [debug]
> ../AGRegexAutoFilter.cpp(42): AMEVENTID#159263: CFilter AgRegexAuto No
> extension Matched the Uri, referer: https://abc.com/nps/
> 2017-02-12T17:15:50.275048+08:00 vhhtsusidm92 httpd[15306]: [debug]
> ../AGFilterPolicy.cpp(33): AMEVENTID#159263: CFilter AgFilterPolicy
> match returned false, referer: https://abc.com/nps/
> 2017-02-12T17:15:50.275141+08:00 vhhtsusidm92 httpd[15306]: [debug]
> ../AGFilterPolicy.cpp(38): AMEVENTID#159263: CFilter AgFilterPolicy no
> match found, referer: https://abc.com/nps/
>
> --Dinesh
>
>


Those log scraps are not very useful to be honest. Do you see an actual
connection request going out to the actual application server?

--
Cheers,
Edward
0 Likes
garima_aggarwal Absent Member.
Absent Member.

Re: CFilter AgRegexAuto No extension Matched the Uri

edmaa;2450803 wrote:
On 2/12/2017 8:36 PM, garima aggarwal wrote:
>


> Now am not getting SSL handshake error. It showing a blank page for me.
>
> Am getting following in error_log
>
> 2017-02-12T17:15:50.274801+08:00 vhhtsusidm92 httpd[15306]: [debug]
> ../AGFilterPolicy.cpp(27): AMEVENTID#159263: CFilter AgFilterPolicy
> Initialized, referer: https://abc.com/nps/
> 2017-02-12T17:15:50.274882+08:00 vhhtsusidm92 httpd[15306]: [debug]
> ../AGRegexAutoFilter.cpp(31): AMEVENTID#159263: CFilter AgRegexAuto
> Compare Initialized, referer: https://abc.com/nps/
> 2017-02-12T17:15:50.274954+08:00 vhhtsusidm92 httpd[15306]: [debug]
> ../AGRegexAutoFilter.cpp(42): AMEVENTID#159263: CFilter AgRegexAuto No
> extension Matched the Uri, referer: https://abc.com/nps/
> 2017-02-12T17:15:50.275048+08:00 vhhtsusidm92 httpd[15306]: [debug]
> ../AGFilterPolicy.cpp(33): AMEVENTID#159263: CFilter AgFilterPolicy
> match returned false, referer: https://abc.com/nps/
> 2017-02-12T17:15:50.275141+08:00 vhhtsusidm92 httpd[15306]: [debug]
> ../AGFilterPolicy.cpp(38): AMEVENTID#159263: CFilter AgFilterPolicy no
> match found, referer: https://abc.com/nps/
>
> --Dinesh
>
>


Those log scraps are not very useful to be honest. Do you see an actual
connection request going out to the actual application server?

--
Cheers,
Edward



Hi Edward

yes, by doing the suggested config changes, request is reaching to app sever.


--Dinesh

0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: CFilter AgRegexAuto No extension Matched the Uri

On 2/12/2017 10:06 PM, garima aggarwal wrote:
>
> yes, by doing the suggested config changes, request is reaching to app
> sever.


Ok, can you then supply a complete error_log for the event?


--
Cheers,
Edward
0 Likes
garima_aggarwal Absent Member.
Absent Member.

Re: CFilter AgRegexAuto No extension Matched the Uri


The issue was with the certificates.

This is a product bug.

https://www.novell.com/support/kb/doc.php?id=7018316
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.