seba4
New Member.
266 views

FormFill & Credentials are sometimes not saved

Hi

I just did a setup of NAM Appliances in a cluster.
This NAM has a service which has FormFill set for login form. Form Fill policy is set for saving/reading data from Shared secret storage.

There is nothing special about it, but there is a catch. I was testing it and i have noticed something strange going on.

! We can't get credentials from service login form, because of this we are using simple custom form. (Dummy HTML form)

What we expect:

  1. User opens a new Browser window and visits portal.company.com which requires user's authentication.
  2. User then authenticates and is redirected to portal Dashboard.
  3. In Dashboard he selects APPMark for service, where he is redirected to login form. (customform.company.com/ris)
  4. Because user currently doesn't have any shared secret set for this service login form opens.
  5. User enters credentials And clicks on Submit
  6. NAM should take credentials and save it in Shared settings. It then redirects to ris.company.com
  7. When ris.company.com opens, NAM injects identity via basic authentication.
  8. User should be logged in now.



    What is happening:

    1. User opens new Browser window and visits portal.company.com which requires user's authentication.
    2. User then authenticates and is redirected to portal Dashboard.
    3. In Dashboard he selects APPMark for service, where he is redirected to login form. (customform.company.com/ris)
    4. Because user currently doesn't have any shared secret set for this service login form opens.
    5. User enters credentials And clicks on Submit
    6. !!!! NAM sometimes doesn't save credentials and user is forwaded to ris.company.com
    7. When ris.company.com opens, NAM tries to inject identity, but it fails because shared settings are empty..


      What i have noticed so far:
      - When user shared setting object in eDir is created, that after this i can succesfully save shared settings.
      - Twice i have event noticed that this user's shared settings object wasn't created but between portal.company.com login and click on AppMark& Login on custom form was 15 minutes apart and in this case credentials were correctly saved.

      I was looking at ESP logs and IDP logs but i can't find anything that could help me.
      Logs: ESP: /var/opt/novell/nam/logs/mag/tomcat/catalina.out
      IDP: /var/opt/novell/nam/logs/idp/tomcat/catalina.out


      Does someone maybe have some similar experience or can help with some information what could i check, debug it.
0 Likes
1 Reply
AutomaticReply Absent Member.
Absent Member.

Re: FormFill & Credentials are sometimes not saved

seba4,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.