esandoval_identicum Absent Member.
Absent Member.
1519 views

Kerberos with Re-Captcha FALLBACK

Hello Community!

I configured Kerberos (its working properly) but when i try to configure a password class as a fallback with Re-Captcha properties it does not work.
Basically when the fallback method is call, form appears without the captcha and when the user fill his credentials and submit the form, the form appears again and the user is not logged into the platform.
In my captcha method, these are my configured properties:

FALLBACK_AUTHCLASS= com.novell.nidp.authentication.local.ProtectedPasswordClass
recaptchaEnable=true
recaptchaSiteKey=(mykey)
recaptchaSecretKey=(mysecretkey)

Any ideas if it is possible to enable re-captcha in a form as a fallback of kerberos method.
I'm currently using NetIQ Access Manager 4.4

If you need additional data, please inform me. Any help would be appreciated.
0 Likes
14 Replies
AutomaticReply Absent Member.
Absent Member.

Re: Kerberos with Re-Captcha FALLBACK

esandoval,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.
https://www.partnernetprogram.com/partnerfinder/find.html

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.microfocus.com/faq.php

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team
http://forums.microfocus.com



0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Kerberos with Re-Captcha FALLBACK

On 09-11-2018 12:04 PM, esandoval identicum wrote:
>
> Hello Community!
>
> I configured Kerberos (its working properly) but when i try to configure
> a password class as a fallback with Re-Captcha properties it does not
> work.
> Basically when the fallback method is call, form appears without the
> captcha and when the user fill his credentials and submit the form, the
> form appears again and the user is not logged into the platform.
> In my captcha method, these are my configured properties:
>
> FALLBACK_AUTHCLASS=
> com.novell.nidp.authentication.local.ProtectedPasswordClass
> recaptchaEnable=true
> recaptchaSiteKey=(mykey)
> recaptchaSecretKey=(mysecretkey)
>
> Any ideas if it is possible to enable re-captcha in a form as a fallback
> of kerberos method.
> I'm currently using NetIQ Access Manager 4.4
>
> If you need additional data, please inform me. Any help would be
> appreciated.
>
>

I just tried this on a 4.4 Sp3 appliance and it worked for me

--
Cheers,
Edward
0 Likes
ScorpionSting Absent Member.
Absent Member.

Re: Kerberos with Re-Captcha FALLBACK

edmaa;2490943 wrote:
On 09-11-2018 12:04 PM, esandoval identicum wrote:
>
> Hello Community!
>
> I configured Kerberos (its working properly) but when i try to configure
> a password class as a fallback with Re-Captcha properties it does not
> work.
> Basically when the fallback method is call, form appears without the
> captcha and when the user fill his credentials and submit the form, the
> form appears again and the user is not logged into the platform.
> In my captcha method, these are my configured properties:
>
> FALLBACK_AUTHCLASS=
> com.novell.nidp.authentication.local.ProtectedPasswordClass
> recaptchaEnable=true
> recaptchaSiteKey=(mykey)
> recaptchaSecretKey=(mysecretkey)
>
> Any ideas if it is possible to enable re-captcha in a form as a fallback
> of kerberos method.
> I'm currently using NetIQ Access Manager 4.4
>
> If you need additional data, please inform me. Any help would be
> appreciated.
>
>

I just tried this on a 4.4 Sp3 appliance and it worked for me

--
Cheers,
Edward


There was a bug with reCAPTCHA in 4.4.1 versions as Google changed the way the reCAPTCHA code worked (you also need to make sure you're using at least the v2 INVISIBLE (see: https://www.netiq.com/documentation/access-manager-44/accessmanager441-release-notes/data/accessmanager441-release-notes.html#t45yp6hwia0m )

Visit my Website for links to Cool Solution articles.
0 Likes
esandoval_identicum Absent Member.
Absent Member.

Re: Kerberos with Re-Captcha FALLBACK

edmaa;2490943 wrote:
On 09-11-2018 12:04 PM, esandoval identicum wrote:
>
> Hello Community!
>
> I configured Kerberos (its working properly) but when i try to configure
> a password class as a fallback with Re-Captcha properties it does not
> work.
> Basically when the fallback method is call, form appears without the
> captcha and when the user fill his credentials and submit the form, the
> form appears again and the user is not logged into the platform.
> In my captcha method, these are my configured properties:
>
> FALLBACK_AUTHCLASS=
> com.novell.nidp.authentication.local.ProtectedPasswordClass
> recaptchaEnable=true
> recaptchaSiteKey=(mykey)
> recaptchaSecretKey=(mysecretkey)
>
> Any ideas if it is possible to enable re-captcha in a form as a fallback
> of kerberos method.
> I'm currently using NetIQ Access Manager 4.4
>
> If you need additional data, please inform me. Any help would be
> appreciated.
>
>

I just tried this on a 4.4 Sp3 appliance and it worked for me

--
Cheers,
Edward



I'll upgrade to 4.4.3. One more question, did you use the same parameters in method ? or you added anything else?

thanks guys!
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Kerberos with Re-Captcha FALLBACK

On 16-11-2018 12:54 PM, esandoval identicum wrote:
>
> edmaa;2490943 Wrote:
>> On 09-11-2018 12:04 PM, esandoval identicum wrote:
>>>
>>> Hello Community!
>>>
>>> I configured Kerberos (its working properly) but when i try to

>> configure
>>> a password class as a fallback with Re-Captcha properties it does not
>>> work.
>>> Basically when the fallback method is call, form appears without the
>>> captcha and when the user fill his credentials and submit the form,

>> the
>>> form appears again and the user is not logged into the platform.
>>> In my captcha method, these are my configured properties:
>>>
>>> FALLBACK_AUTHCLASS=
>>> com.novell.nidp.authentication.local.ProtectedPasswordClass
>>> recaptchaEnable=true
>>> recaptchaSiteKey=(mykey)
>>> recaptchaSecretKey=(mysecretkey)
>>>
>>> Any ideas if it is possible to enable re-captcha in a form as a

>> fallback
>>> of kerberos method.
>>> I'm currently using NetIQ Access Manager 4.4
>>>
>>> If you need additional data, please inform me. Any help would be
>>> appreciated.
>>>
>>>

>> I just tried this on a 4.4 Sp3 appliance and it worked for me
>>
>> --
>> Cheers,
>> Edward

>
>
> I'll upgrade to 4.4.3. One more question, did you use the same
> parameters in method ? or you added anything else?
>
> thanks guys!
>
>

I used the same parameters as you specified and as per Ben's (ScorpionSting) comment, i used the the v2 invisible method. I haven't tried using v3.


--
Cheers,
Edward
0 Likes
esandoval_identicum Absent Member.
Absent Member.

Re: Kerberos with Re-Captcha FALLBACK

edmaa;2490956 wrote:
On 16-11-2018 12:54 PM, esandoval identicum wrote:
>
> edmaa;2490943 Wrote:
>> On 09-11-2018 12:04 PM, esandoval identicum wrote:
>>>
>>> Hello Community!
>>>
>>> I configured Kerberos (its working properly) but when i try to

>> configure
>>> a password class as a fallback with Re-Captcha properties it does not
>>> work.
>>> Basically when the fallback method is call, form appears without the
>>> captcha and when the user fill his credentials and submit the form,

>> the
>>> form appears again and the user is not logged into the platform.
>>> In my captcha method, these are my configured properties:
>>>
>>> FALLBACK_AUTHCLASS=
>>> com.novell.nidp.authentication.local.ProtectedPasswordClass
>>> recaptchaEnable=true
>>> recaptchaSiteKey=(mykey)
>>> recaptchaSecretKey=(mysecretkey)
>>>
>>> Any ideas if it is possible to enable re-captcha in a form as a

>> fallback
>>> of kerberos method.
>>> I'm currently using NetIQ Access Manager 4.4
>>>
>>> If you need additional data, please inform me. Any help would be
>>> appreciated.
>>>
>>>

>> I just tried this on a 4.4 Sp3 appliance and it worked for me
>>
>> --
>> Cheers,
>> Edward

>
>
> I'll upgrade to 4.4.3. One more question, did you use the same
> parameters in method ? or you added anything else?
>
> thanks guys!
>
>

I used the same parameters as you specified and as per Ben's (ScorpionSting) comment, i used the the v2 invisible method. I haven't tried using v3.


--
Cheers,
Edward



I updated my nam, also created a new account with v2 invisible mode, but when i enable in the method those parameters, the kerberos contract shows me the form (captcha never appears) and when i submit my form with right credentials, the form appears again to be filled.
any ideas? i did not find anything in the logs 😞
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Kerberos with Re-Captcha FALLBACK

On 19-11-2018 8:54 AM, esandoval identicum wrote:
>


> I updated my nam, also created a new account with v2 invisible mode, but
> when i enable in the method those parameters, the kerberos contract
> shows me the form (captcha never appears) and when i submit my form with
> right credentials, the form appears again to be filled.
> any ideas? i did not find anything in the logs 😞
>
>


ok, seems i buggered up my testing a little here. It seems indeed that the fallback parameters are being ignored but because i had captcha configured
on my out of the box secure name/password form class it does show captcha when doing a fallback. Is that an option for you?

--
Cheers,
Edward
0 Likes
esandoval_identicum Absent Member.
Absent Member.

Re: Kerberos with Re-Captcha FALLBACK

How did you configure that Edward? i configured a class with that and put the contract as default, is that the way?

edmaa;2491071 wrote:
On 19-11-2018 8:54 AM, esandoval identicum wrote:
>


> I updated my nam, also created a new account with v2 invisible mode, but
> when i enable in the method those parameters, the kerberos contract
> shows me the form (captcha never appears) and when i submit my form with
> right credentials, the form appears again to be filled.
> any ideas? i did not find anything in the logs 😞
>
>


ok, seems i buggered up my testing a little here. It seems indeed that the fallback parameters are being ignored but because i had captcha configured
on my out of the box secure name/password form class it does show captcha when doing a fallback. Is that an option for you?

--
Cheers,
Edward
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Kerberos with Re-Captcha FALLBACK

On 23-11-2018 6:44 AM, esandoval identicum wrote:
>
> How did you configure that Edward? i configured a class with that and
> put the contract as default, is that the way?
>


I used the out of the box secure name/password form class and enabled it on that. It it also set as my default contract


--
Cheers,
Edward
0 Likes
esandoval_identicum Absent Member.
Absent Member.

Re: Kerberos with Re-Captcha FALLBACK

are you sure edward? i put

FALLBACK_AUTHCLASS com.novell.nidp.authentication.local.ProtectedPasswordClass

and configure the out-of-the-box class with captcha and it does not work 😞
do you configured anything else? do you have your login.jsp modified?
I debbugged with a custom class and logs (other approach) and i see that the fallback first shows your configured jsp (normal behaviour is authenticate with my class and then, let the class show the jsp)

edmaa;2491431 wrote:
On 23-11-2018 6:44 AM, esandoval identicum wrote:
>
> How did you configure that Edward? i configured a class with that and
> put the contract as default, is that the way?
>


I used the out of the box secure name/password form class and enabled it on that. It it also set as my default contract


--
Cheers,
Edward
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Kerberos with Re-Captcha FALLBACK

On 28-11-2018 1:04 PM, esandoval identicum wrote:
>
> are you sure edward? i put
>
> FALLBACK_AUTHCLASS
> com.novell.nidp.authentication.local.ProtectedPasswordClass
>
> and configure the out-of-the-box class with captcha and it does not work
> 😞
> do you configured anything else? do you have your login.jsp modified?
> I debbugged with a custom class and logs (other approach) and i see
> that the fallback first shows your configured jsp (normal behaviour is
> authenticate with my class and then, let the class show the jsp)


Let me check with a non-appliance


--
Cheers,
Edward
0 Likes
Highlighted
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Kerberos with Re-Captcha FALLBACK

On 28-11-2018 1:04 PM, esandoval identicum wrote:
>
> are you sure edward? i put
>
> FALLBACK_AUTHCLASS
> com.novell.nidp.authentication.local.ProtectedPasswordClass
>
> and configure the out-of-the-box class with captcha and it does not work
> 😞
> do you configured anything else? do you have your login.jsp modified?
> I debbugged with a custom class and logs (other approach) and i see
> that the fallback first shows your configured jsp (normal behaviour is
> authenticate with my class and then, let the class show the jsp)


Hmm...seems the appliance works slightly different as on a stand alone IDP it indeed doesn't work. I don't even know why it then does work on the (my)
appliance to be honest


--
Cheers,
Edward
0 Likes
ratclma Absent Member.
Absent Member.

Re: Kerberos with Re-Captcha FALLBACK

edmaa;2491666 wrote:
On 28-11-2018 1:04 PM, esandoval identicum wrote:
>
> are you sure edward? i put
>
> FALLBACK_AUTHCLASS
> com.novell.nidp.authentication.local.ProtectedPasswordClass
>
> and configure the out-of-the-box class with captcha and it does not work
> 😞
> do you configured anything else? do you have your login.jsp modified?
> I debbugged with a custom class and logs (other approach) and i see
> that the fallback first shows your configured jsp (normal behaviour is
> authenticate with my class and then, let the class show the jsp)


Hmm...seems the appliance works slightly different as on a stand alone IDP it indeed doesn't work. I don't even know why it then does work on the (my)
appliance to be honest


--
Cheers,
Edward


Hi,
I have this same problem, using a protectedpassword class with reCaptcha enabled on a NAM 4.4.3 IDP running on RHEL. As recommended I enabled Invisible ReCaptcha. Did anybody find a solution or is it a bug?
Thanks
Mark
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Kerberos with Re-Captcha FALLBACK

On 04-01-2019 12:04 AM, ratclma wrote:
>


> I have this same problem, using a protectedpassword class with reCaptcha
> enabled on a NAM 4.4.3 IDP running on RHEL. As recommended I enabled
> Invisible ReCaptcha. Did anybody find a solution or is it a bug?
> Thanks
> Mark


It works fine with just the password class. The original poster wanted to use it with the fallback option on the kerberos class.

--
Cheers,
Edward
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.