Highlighted
Absent Member.
Absent Member.
1723 views

Kerberos with Re-Captcha FALLBACK

Hello Community!

I configured Kerberos (its working properly) but when i try to configure a password class as a fallback with Re-Captcha properties it does not work.
Basically when the fallback method is call, form appears without the captcha and when the user fill his credentials and submit the form, the form appears again and the user is not logged into the platform.
In my captcha method, these are my configured properties:

FALLBACK_AUTHCLASS= com.novell.nidp.authentication.local.ProtectedPasswordClass
recaptchaEnable=true
recaptchaSiteKey=(mykey)
recaptchaSecretKey=(mysecretkey)

Any ideas if it is possible to enable re-captcha in a form as a fallback of kerberos method.
I'm currently using NetIQ Access Manager 4.4

If you need additional data, please inform me. Any help would be appreciated.
0 Likes
14 Replies
Highlighted
Knowledge Partner Knowledge Partner
Knowledge Partner

On 28-11-2018 1:04 PM, esandoval identicum wrote:
>
> are you sure edward? i put
>
> FALLBACK_AUTHCLASS
> com.novell.nidp.authentication.local.ProtectedPasswordClass
>
> and configure the out-of-the-box class with captcha and it does not work
> 😞
> do you configured anything else? do you have your login.jsp modified?
> I debbugged with a custom class and logs (other approach) and i see
> that the fallback first shows your configured jsp (normal behaviour is
> authenticate with my class and then, let the class show the jsp)


Hmm...seems the appliance works slightly different as on a stand alone IDP it indeed doesn't work. I don't even know why it then does work on the (my)
appliance to be honest


--
Cheers,
Edward
0 Likes
Highlighted
Absent Member.
Absent Member.

edmaa;2491666 wrote:
On 28-11-2018 1:04 PM, esandoval identicum wrote:
>
> are you sure edward? i put
>
> FALLBACK_AUTHCLASS
> com.novell.nidp.authentication.local.ProtectedPasswordClass
>
> and configure the out-of-the-box class with captcha and it does not work
> 😞
> do you configured anything else? do you have your login.jsp modified?
> I debbugged with a custom class and logs (other approach) and i see
> that the fallback first shows your configured jsp (normal behaviour is
> authenticate with my class and then, let the class show the jsp)


Hmm...seems the appliance works slightly different as on a stand alone IDP it indeed doesn't work. I don't even know why it then does work on the (my)
appliance to be honest


--
Cheers,
Edward


Hi,
I have this same problem, using a protectedpassword class with reCaptcha enabled on a NAM 4.4.3 IDP running on RHEL. As recommended I enabled Invisible ReCaptcha. Did anybody find a solution or is it a bug?
Thanks
Mark
0 Likes
Highlighted
Knowledge Partner Knowledge Partner
Knowledge Partner

On 04-01-2019 12:04 AM, ratclma wrote:
>


> I have this same problem, using a protectedpassword class with reCaptcha
> enabled on a NAM 4.4.3 IDP running on RHEL. As recommended I enabled
> Invisible ReCaptcha. Did anybody find a solution or is it a bug?
> Thanks
> Mark


It works fine with just the password class. The original poster wanted to use it with the fallback option on the kerberos class.

--
Cheers,
Edward
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.