-Magnus- Super Contributor.
Super Contributor.
522 views

Upgrade from 4.2.1 to 4.3 fails in prerequisite test.


Hi,
I tried to upgrade my 4.2.1 appliance today, and I started with the OS
upgrade, it worked without any problem (except for the documentation
that refers to 4.2 instead of 4.3)
But when I came to the NAM part i got stuck in the prerequisite test :


Code:
--------------------
NAMAPP:~/NAM-singlebox-4.3.0.0-392 # ./sb_upgrade.sh
Ensure 1800MB is available...
Checking the disk information...
Cannot upgrade components from [ 4.2.1.0.29 ] to [ 4.3.0.0-392 ].
Terminating the installation...
--------------------


Then I looked in to the underlaying script and found out that 4.2.1 is
not a supported version to upgrade from ?


Code:
--------------------
supportedVersions="4.1.2.0\|4.2.0.0\|4.2.2.0\|4.2.3.0\|4.3.0.0"
--------------------


Is this correct ? I could not find anything about that in the readme or
appliance documentation ?
Or is it fixed by just adding 4.2.1 to the supportedVersions variable ?

Regards Magnus


--
magnus
------------------------------------------------------------------------
magnus's Profile: https://forums.netiq.com/member.php?userid=283
View this thread: https://forums.netiq.com/showthread.php?t=56838

0 Likes
2 Replies
ncashell1 Absent Member.
Absent Member.

Re: Upgrade from 4.2.1 to 4.3 fails in prerequisite test.

Hi Magnus, you are right - the 4.2.1 to 4.3 upgrade is not a supported platform. You will need to go to 4.2.2 and then 4.3. The reason we support 4.2.0 is that we have an upgrade path for customers on 4.0.x to go to 4.2.0, and then to 4.3. We also provided an upgrade path from latest 4.2 SP at the time of release to 4.3. We are looking to improve next time and offer upgrade options from more platforms. HTH, neil
0 Likes
-Magnus- Super Contributor.
Super Contributor.

Re: Upgrade from 4.2.1 to 4.3 fails in prerequisite test.


ncashell;272367 Wrote:
> Hi Magnus, you are right - the 4.2.1 to 4.3 upgrade is not a supported
> platform. You will need to go to 4.2.2 and then 4.3. The reason we
> support 4.2.0 is that we have an upgrade path for customers on 4.0.x to
> go to 4.2.0, and then to 4.3. We also provided an upgrade path from
> latest 4.2 SP at the time of release to 4.3. We are looking to improve
> next time and offer upgrade options from more platforms. HTH, neil


Thank you Niel!
It was stupid of me, I would of course have looked in the full
documentation AM instead of just Appliance doc.
The 4.3 appliance documentation has some work left.
//Magnus


--
magnus
------------------------------------------------------------------------
magnus's Profile: https://forums.netiq.com/member.php?userid=283
View this thread: https://forums.netiq.com/showthread.php?t=56838

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.