Anonymous_User Absent Member.
Absent Member.
424 views

UNIX_ExecUtil KS missing some of standard output


When running the UNIX_ExecUtil KS, it appears that standard output from
the Linux side is not being parsed by the KS.

For example, standard out for our Linux script is as follows. The
portion highlighted in red is mostly missing in the KS output. Even what
is there shows up at the end instead of in the middle (in green).



log_file= java.io.FileNotFoundException: *(No such file or
directory)
[log_file-> System.out]
Creating summariser <summary>
Created the tree successfully using
/home/sklong/monitor/jmx/FullPersonRequestProxy.jmx
Starting the test @ Tue Nov 04 11:11:56 EST 2014 (1415117516828)
Waiting for possible shutdown message on port 4445
-*1415117517683,174,FullPersonRequestProxy PROD
QueryRequest,200,OK,FullPersonRequestProxy PROD Basic Test
1-1,text,false,Test failed: text expected to contain
/<PublicId>P98*-90001</PublicId>/,2766,0
summary = * * *1 in * 0.2s = * *5.7/s Avg: * 174 Min: * 174 Max: * 174
Err: * * 1 (100.00%)
Tidying up ... * *@ Tue Nov 04 11:11:57 EST 2014 (1415117517916)
.... end of run


The KS shows this as standard output:


log_file= java.io.FileNotFoundException: (No such file or
directory)
[log_file-> System.out]
Creating summariser <summary>
Created the tree successfully using
/home/sklong/monitor/jmx/FullPersonRequestProxy.jmx
Starting the test @ Tue Nov 04 11:16:31 EST 2014 (1415117791782)
Waiting for possible shutdown message on port 4445
summary + 1 in 0.2s = 4.6/s Avg: 219 Min: 219 Max: 219
Err: 1

(100.00%) Active: 1 Started: 1 Finished: 0
summary = 1 in 0.2s = 4.6/s Avg: 219 Min: 219 Max: 219
Err: 1

(100.00%)
Tidying up ... @ Tue Nov 04 11:16:32 EST 2014 (1415117792989)
.... end of run
90001</PublicId>/,2766,0

Any idea why this is being stripped out? We have the KS looking for the
"Test failed", but it is not finding it.

Steve


--
stevelee
------------------------------------------------------------------------
stevelee's Profile: https://forums.netiq.com/member.php?userid=7211
View this thread: https://forums.netiq.com/showthread.php?t=52103

0 Likes
1 Reply
Anonymous_User Absent Member.
Absent Member.

Re: UNIX_ExecUtil KS missing some of standard output


It might be best to open a ticket with support... but also, you can
enable debugging with this KS. If you do that, you will find a file
named UNIX_ExecUtil_[JobID].log in the log directory (default is
/usr/netiq/AM/log). That should show the information that was processed
by the running job. Does that hold the output you were expecting?


--
Andy Doran
Software Engineer Consultant (NetIQ)
------------------------------------------------------------------------
andy_doran's Profile: https://forums.netiq.com/member.php?userid=3937
View this thread: https://forums.netiq.com/showthread.php?t=52103

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.