Absent Member.. ChrisMov Absent Member..
Absent Member..
1205 views

[BSM] Probe isn't working

Hi,
I'm experiencing a problem with BSM.

I have a BSM instance and two probes. From last Thursday a probe isn't working as expected and BSM is not able to gather its information.

We have found that the probe could not run scripts ( "no data arrived" error when running scripts on BPMA) because its disk was full so we have freed 1Gb of memory and BPMA has started running scripts again.
Now the problem is that even if we have freed 1gb of memory BSM still cannot show data arriving from that probe.
(The generated graphs are related only to data coming from probe1)

Additional info:
-the probe can reach the BSM machine (seen from BPMA)
-BSM shows both probes
-ports 80 on BSM machine is open

-in logs we have found some errors for the probe which is working. They are all similar to this one:
2015-07-28 03:00:11,918 [ajp-0.0.0.0-8009-4] (Dispatcher.java:1196) ERROR - Response of invocation is Failure: Failed to register BPM Agent. Agent Name: XYZ-probe Error: Failed to get BPM Host. System error occurred: Get BPM Host failed with multiple register request. HostName=XYZ-probe lastRequest=1438045211409 The thrown message is: (com.mercury.am.eum.shared.management.exceptions.EumGeneralException) Failed to get BPM Host. System error occurred: Get BPM Host failed with multiple register request. HostName=MOV-BPM7 lastRequest=1438045211409


Any suggestion?

Thanks in advance!

Tags (1)
0 Likes
4 Replies
CLEFEBVRE Respected Contributor.
Respected Contributor.

Re: [BSM] Probe isn't working

Hello,

 

"Now the problem is that even if we have freed 1gb of memory BSM still cannot show data arriving from that probe." : So, it's possible some files on your probe have been corrupted. Could you try this :

 

- Stop "HP Business Process Management" service.

- Rename the workspace folder to workspace.old ? (Depending on your OS version and installation path, you should find this folder in C:\ProgramData\HP\BPM\ for example).

- Start "HP Business Process Management" service.

 

I do this each time I have a problem with a probe and it often solves my problem!

 

Regards,

  Christophe

0 Likes
Highlighted
Absent Member.. ChrisMov Absent Member..
Absent Member..

Re: [BSM] Probe isn't working

Hello,

I've stopped the HP services.
I've found the path C:\ProgramData\HP\BSM  as workspace but it cannot be renamed due to "opened files or folder". Therefore I've decided to rename all the content except C:\ProgramData\HP\BSM\tmp  which is the folder that gives problems.
I've restarted the HP services, the renamed folders have been generated but the problem with the probe is still there: data are gathered only from the first probe and the second is detected and connected but don't partecipate.

0 Likes
CLEFEBVRE Respected Contributor.
Respected Contributor.

Re: [BSM] Probe isn't working

You shouldn't have opened files if BPM is stopped. When you stop BPM, kill remaining Firefox and IE process if needed. You can also disable the BPM service, restart the computer, rename the folder and enable and start the BPM service.
0 Likes
Absent Member.. ChrisMov Absent Member..
Absent Member..

Re: [BSM] Probe isn't working

I disabled HP services from regedit and restarted the machine.
The workspace was completely unlocked so I have renamed its main directory.
Then I have enabled HP services and I have restarted the machine.
Now BPM works fine but unfortunately the problem with that probe still persists.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.