Absent Member.. fully Absent Member..
Absent Member..
109 views

CI Hint Issue on BSM Connector

Hi,

Using BSM Connector 9.23 and BSM 9.23 I am running in to an issue with CI Hints and a Metric Policy.

For example I want to map the following hint. business_transaction:#call:RMIService:PSI

 

If I check this hint in the JMX Console name=CiResolverMBean I get ambiguities. If I change this hint to  business_transaction:"#call:RMIService:PSI" in the CiResolverMBean the ambiguity is resolved. However can this be recreated in a BSMC policy?

On the BSMC in the Metric Policy > Rules > Attributes > Metrics > CI Hint

I have the following.

"business_transaction:" + $group3 + " " + $group8

 

This results in ambiguity. How can the quotes be escaped so the CI can be grouped as I did in the CiResolverMBean?

Regards,

Bach

0 Likes
3 Replies
Established Member.. kenneth.gonzale
Established Member..

Re: CI Hint Issue on BSM Connector

Hi,

Have you tried to escape with backslash (\")?
Kenneth Gonzalez
HP Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums
0 Likes
Absent Member.. fully Absent Member..
Absent Member..

Re: CI Hint Issue on BSM Connector

Hi,

I wish that would have worked but creating a line like this in the BSMC policy "business_transaction:\"" + $group3 + " " + $group8 + "\""

Results in the /opt/HP/BSM/log/wde/wdePublishedSamples.log on the BSM GWS.

Sample_ss_t(MFSample, seq=0):
  eti_id                  = 'Binary[16]:0x67b72128d4674bbc8440ebba986331b2'
  u_iConnectionId         = '7803928'
  szMeasurementName       = 'RMI-RespTime W'
  DowntimeState           = '0'
  u_iQuality              = '1'
  time_stamp              = '1.395316476E9' (2014-03-20 12:54:36)
  instance_id             = '1'
  dTime                   = '1.395316476E9'
  profile_name            = 'SCOM01'
  szMonitorName           = 'Business Transaction'
  customer_name           = 'Default Client'
  u_iTargetId             = '7800349'
  szTargetName            = '#psi:getserverinfo:'
  ci_hint                 = 'business_transaction:\"#psi:getServerInfo: W\"'
  pmdb                    = '0'
  szCategoryName          = 'rmi-resptime w'
  u_iSessionId            = '222'
  szConnectionName        = 'EMS:19 #psi:getServerInfo:37 ELAN Log Metric #psi:getServerInfo: W9 200930212'
  u_iCategoryId           = '7803920'
  u_iMsmtQuality          = '0'
  u_iStatus               = '0'
  start_time              = '1.395316476E9'
  dValue                  = '31.0'
  u_iMonitorId            = '7800288'
  measurement_description = 'RMI-RespTime W'
  szSessionName           = 'SCOM01'
  u_iMeasurementId        = '7803929'
  u_iHasProperty          = '0'

 

So it takes the \" literally. This is odd. With the \ the mapping doesn't work though either.

 

0 Likes
Established Member.. kenneth.gonzale
Established Member..

Re: CI Hint Issue on BSM Connector

Hi,

I'd try some other combinations such: ^" or \\"
Kenneth Gonzalez
HP Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.