Highlighted
Absent Member.. FrankyVally Absent Member..
Absent Member..
132 views

Operator initiated actions set in OMW are run with the incorrect user in OMi

Hello,

 

Here's our environment:

 

BSM 9.23 on Windows

OMW 9.00 on Windows

OM Agent 11.13 on either Windows or Linux

 

When we start an operator initiated actions set in OMW, they are run with the incorrect user in OMi.  It uses our integration service account we steup for OMW to OMi integration.  We would like it to run with the rights of the user launching it from OMi. 

 

It is an important security issue for us.

 

We need to make sure that the person that is running the operator initiated action as proper rights to do so.

 

Is there a way to do that?

 

Thanks and regards,

Tags (4)
0 Likes
3 Replies
Micro Focus Expert
Micro Focus Expert

Re: Operator initiated actions set in OMW are run with the incorrect user in OMi

You can configure the tool with an "operator specified user"

you can define this in the "Target" setting tab of the tool configuration dialog .
0 Likes
Absent Member.. FrankyVally Absent Member..
Absent Member..

Re: Operator initiated actions set in OMW are run with the incorrect user in OMi

Hello Pat,

Unless I misinterpret your message, the only thing that can be done from an OMW side is uncheck the use $AGENT_USER to force the user to enter the username/password.

What we are trying to accomplish is to use the user which is authenticated in OMi to own messages and/or run operator initiated actiona.

We are confronted with the same issue when taking ownership of a case in OMi, it shows as the integration service account in OMW instead of the actual user who took ownership.

Any way around that?

Thanks and regards
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Operator initiated actions set in OMW are run with the incorrect user in OMi

hi Franky,

 

regarding your first remark to "uncheck the use $AGENT_USER to force the user to enter the username/password" i was referring to the tool configuration as follows:

 


 

For the second question, i would suggest to grant the appropriate roles to the operator (it must be a business user).

 

Choose the Operations Management as context, and try the different roles to find out what works best for you.

 

There are several operations you can setup for your user.

 

Maybe you've set it up already and it doesn't work?

 

Please share screenshots of the user settings to have a look at it.

 

Best regards,
PatW

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.