Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
testbravo Super Contributor.
Super Contributor.
359 views

RUM Probe v9.30 restarting after upgradation

Hi ALL,

 

We have upgradaded RUM from v9.25 to v9.30 but Probe service restarting automatically.

We are getting below error.

 

02/12 13:34:14  (INFO) Start the main service thread
02/12 13:34:14  (INFO) rp_monitor ssl and CA verification of clients is enabled but no setting local_client_cert is defined in rpsecurity.conf. Trying legacy setting ssl_cert
02/12 13:34:14  (INFO) rp_monitor ssl_cert is neither defined. defaulting to etc/rum_probe/rum-probe-server.crt
02/12 13:34:14  (INFO) rp_monitor ssl and CA verification of clients is enabled but no setting local_client_key is defined in rpsecurity.conf. Trying legacy setting ssl_key
02/12 13:34:14  (INFO) rp_monitor ssl_key is neither defined. defaulting to etc/rum_probe/rum-probe-server.key
02/12 13:34:14  (INFO) rp_monitor using the following security definitions:
02/12 13:34:14  (INFO) rp_monitor    ssl_cert : E:\HPRumProbe\etc/rum_probe/rum-probe-server.crt
02/12 13:34:14  (INFO) rp_monitor    ssl_key : E:\HPRumProbe\etc/rum_probe/rum-probe-server.key
02/12 13:34:36  (WARN) rp_monitor No ping failure : 1
02/12 13:34:36  (WARN) rp_monitor Error string: 500 read failed: Unknown error
02/12 13:34:38  (INFO) Ping succeeded on https://127.0.0.1:2020/ping.xml
02/12 13:35:40  (WARN) rp_monitor No ping failure : 1
02/12 13:35:40  (WARN) rp_monitor Error string: 500 Connect failed: connect: Unknown error; Unknown error

 

Kindly help here.

0 Likes
4 Replies
MikoMak Trusted Contributor.
Trusted Contributor.

Re: RUM Probe v9.30 restarting after upgradation

HI ,

I had a simalr problem and i found that deleting the cache can help.

it's not a permanent solution , but it help for that monent.

Cache files can be found under : <install Dir >:\HPRumProbe\var\spool\rum_probe\cache

look under Savefull. there should be a huge file that sometimes need to be remove.

Stop the probe before doing it and then start it again.

Hope it helps.

 

 

 

0 Likes
Highlighted
testbravo Super Contributor.
Super Contributor.

Re: RUM Probe v9.30 restarting after upgradation

Hi MikoMak,

Kindly confirm which files we have to remove from cache folder or all files under it..??

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: RUM Probe v9.30 restarting after upgradation

Hi Testbravo,

1. Stop the Probe.

2. Delete \var\spool\rum_probe\cache folder with content;

3. Start Probe;

Best regards, Alexey

0 Likes
Contributor.. Dave D. Contributor..
Contributor..

Re: RUM Probe v9.30 restarting after upgradation

Hi, did you ever find permanent resolution for this issue?  We just upgraded from RUM 9.26 to 9.30 and are experiencing the same.  Thanks!

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.