kyarali Trusted Contributor.
Trusted Contributor.
1029 views

Sitescope 11.50 SSL Issue

Hello

We want to connect our Sitescope via https. When we try to access Sitescope via https , I'm getting the below's error.

Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to https://localhost:8443 again. If this error persists, it is possible that this site uses an unsupported protocol or cipher suite such as RC4 (link for the details), which is not considered secure. Please contact your site administrator.

I checked Advanced settings but TLS 1.0, 1.1  and 1.2 has already turned on. What would be the possible for this issue?

Thanks

Labels (1)
0 Likes
5 Replies
Regular Contributor.. Sttefany_P_SIS Regular Contributor..
Regular Contributor..

Re: Sitescope 11.50 SSL Issue

Hello, 

We hope you are doing good. 

This can be caused by the RC4 cipher you can disable this from SiteScope server and then try to generate the report again, please follow this steps: 

To disable the RC4 cipher, please follow this steps:

 

  1. Stop SiteScope service.
  2. After doing that, please open the file java.security that is located on the following path: C:\SiteScope\java\lib\security\java.security.
  3. Then please add this constraint at the end of the file jdk.tls.disabledAlgorithms=RC4.
  4. To finalize, please restart the service and try to generate the report.

Please let us know the results. 

 

Regards, 

Sttefany Padilla C.
SiteScope | Customer Support Engineer

 

 

0 Likes
kyarali Trusted Contributor.
Trusted Contributor.

Re: Sitescope 11.50 SSL Issue

Hello

Thanks for update. I added the statement which you have provided to me but the same issue still persist. Sitescope can run via http. I'm sharing below Sitescope error.log file.Also you can find server.xml and master.config file's  Could you check the log and  if it is possible share you opinion about the issue?

2018-07-07 22:55:33,543 [SiteScope Main] (SiteScopeGroup.java:743) INFO  - Starting HTTPS server...
2018-07-07 22:55:33,543 [SiteScope Main] (SiteScopeGroup.java:845) INFO  -  
2018-07-07 22:55:33,543 [SiteScope Main] (SiteScopeGroup.java:846) INFO  -  For a Secure Connection
2018-07-07 22:55:33,543 [SiteScope Main] (SiteScopeGroup.java:847) INFO  - Open your web browser to:
2018-07-07 22:55:33,543 [SiteScope Main] (SiteScopeGroup.java:848) INFO  -   https://fe80:0:0:0:6dd3:7b9c:a0e:ce%5:8443
2018-07-07 22:55:33,559 [SiteScope Main] (SiteScopeGroup.java:334) INFO  - Starting common scheduler...
2018-07-07 22:55:33,559 [SiteScope Main] (SiteScopeGroup.java:354) INFO  - Starting maintenance scheduler...
2018-07-07 22:55:33,668 [SiteScope Main] (SiteScopeGroup.java:624) INFO  - Starting topaz manager
2018-07-07 22:55:33,668 [SiteScope Main] (SiteScopeGroup.java:626) INFO  - Topaz manager started.
2018-07-07 22:55:33,668 [SiteScope Main] (SiteScopeGroup.java:466) INFO  - Starting monitor scheduler...
2018-07-07 22:55:33,668 [SiteScope Main] (SiteScopeGroup.java:471) INFO  - Starting report scheduler...
2018-07-07 22:55:33,684 [SiteScope Main] (SiteScopeGroup.java:487) INFO  - Starting analytics scheduler...
2018-07-07 22:55:33,684 [SiteScope Main] (SiteScopeGroup.java:498) INFO  -  
2018-07-07 22:55:33,684 [SiteScope Main] (SiteScopeGroup.java:499) INFO  - SiteScope is active...
2018-07-07 22:55:33,699 [SiteScope Main] (SiteScopeGroup.java:523) INFO  - SiteScope Starting all monitors
2018-07-07 22:55:33,699 [SiteScope Main] (SiteScopeGroup.java:527) INFO  - SiteScope Start monitors completed
2018-07-07 22:55:33,730 [SiteScope Main] (SiteScopeGroup.java:541) INFO  - SiteScope Startup Completed] (SiteScopeGroup.java:541) INFO  - SiteScope Startup Completed

server.xml

 <Connector port="8443" maxHttpHeaderSize="8192"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"

master.config

_httpSecurePort=8899

_httpsActivePort=8899

Thanks

0 Likes
kyarali Trusted Contributor.
Trusted Contributor.

Re: Sitescope 11.50 SSL Issue

Hello

Still I'm getting below messages  when I try to open the page via https in IE. Could you help me to solve this issue?

This page can’t be displayed

Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to https://xxx::8443 again. If this error persists, it is possible that this site uses an unsupported protocol or cipher suite such as RC4 (link for the details), which is not considered secure. Please contact your site administrator.

Thanks

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Sitescope 11.50 SSL Issue

Hi kyarali,

it seems the logs you advertised didn't make it here, so no error can be seen.

As per the message there can be two issues:
- TLS 1.0, TLS 1.1, and TLS 1.2 are DISABLED
- an unsupported protocol or cipher suite such as RC4 is ENABLED

You have been asked to edit the file <SiteScope>\java\lib\security\java.security and add to the end of the file the line
jdk.tls.disabledAlgorithms=RC4
followed by a SiteScope restart

As the issue persists, you might wanna follow the steps listed in the link mentioned in the error message:
 https://support.microsoft.com/en-us/help/3151631/rc4-cipher-is-no-longer-supported-in-internet-explorer-11-or-microsoft

Greetings
Siggi

Customer Support
Micro Focus

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
kyarali Trusted Contributor.
Trusted Contributor.

Re: Sitescope 11.50 SSL Issue

Hello

I have already changed java.security file but the issue still exist. May the issue realted with master.config file? I'm sharing below our master.config file? Could you check it?

 

    <Connector port="8443" maxHttpHeaderSize="8192"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75" SSLEnabled="true"
               enableLookups="false" disableUploadTimeout="true"
               acceptCount="100" scheme="https" secure="true"
               clientAuth="false" sslProtocol="TLS"
               compression="on"
               compressionMinSize="2048"
               noCompressionUserAgents="gozilla, traviata"
               compressableMimeType="text/html,text/xml,text/javascript,text/css,image/x-icon,application/json"
               server="******"
               sslEnabledProtocols="TLSv1,TLSv1.1,SSLv2Hello" keystoreFile="E::\SiteScope\groups\serverKeystore"
      keystorePass="xxx"
     />

Thanks

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.