Absent Member.
Absent Member.
762 views

Connector is working standalone however gives error as service

Jump to solution

Dears,

Please find below the error that I am facing when I run my smart connector for Kaspersky DB as a service. (It doesn't collect logs).

However it is working fine when its run as a standalone application.

java.lang.UnsupportedOperationException: Unable to detect database version.

Tried version [10.0]. ERROR: [Cannot open database "KAV" requested by the login. The login failed. ClientConnectionId:6586aafd-4316-4f3a-b020-26ce1892f422]

Tried version [8.0]. ERROR: [Cannot open database "KAV" requested by the login. The login failed. ClientConnectionId:c15f2fd7-b3bc-40a4-8fd3-011fd164f96d]

Yesterday it was working fine, but when I came office this morning, it was stopped and in error logs i found this error.

What might be the issue?

Labels (3)
Tags (1)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.
Absent Member.

Re: Connector is working standalone however gives error as service

Jump to solution

Solution was to start the service using the user credentials which have actually access on the required DB. In properties of service running, the credentials were entered and it is running fine.

View solution in original post

0 Likes
3 Replies
Highlighted
Super Contributor.
Super Contributor.

Re: Connector is working standalone however gives error as service

Jump to solution

Hi Bilal,

The first place I'd check is with a Kaspersky admin. Looks like an account login issue (i.e. a password issue), but see below a couple of things to check if it's not:

  • Does your ArcSight account still have permissions to login to the KAV database?
  • Is the KAV DB machine still listening on the configured port you are using?
  • What version of Kaspersky is this? Has it been upgraded at all since it last worked?
  • If you can successfully login using a query analyser and run the following queries (depending on your version) it should work again:
    • Kaspersky v8 - SELECT TOP 1 product_displ_version FROM ev_event
    • Kaspersky v10 - SELECT TOP 1 nVServerId FROM ev_event

Cheers

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Connector is working standalone however gives error as service

Jump to solution

Thank you bkilore, however solution has been found.

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Connector is working standalone however gives error as service

Jump to solution

Solution was to start the service using the user credentials which have actually access on the required DB. In properties of service running, the credentials were entered and it is running fine.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.