Highlighted
Brandon Valued Contributor.
Valued Contributor.
507 views

Console is not honoring the timezone of the machine it is installed on....

Everything I read in the docs suggest that the timezone of the machine that the ESM console is installed on is what will show (exceptions have been noted).

Has anyone been able to successfully get the console to show other than what ESM is configured for? I'm sure I'm just missing something...This is actually a new request in my 7 years experience with ArcSight 😐

Labels (1)
Tags (1)
0 Likes
2 Replies
maystrovichva Super Contributor.
Super Contributor.

Re: Console is not honoring the timezone of the machine i...

Hello, Brandon.

If your ESM console shows incorrect timezone, you can try this (for Windows):

1. open command line

2. enter the following command:

tzutil /g

This command shows the name of current system timezone. For example,

tzutil.png

3. Go to %ARCSIGHT_CONSOLE_HOME%\current\jre\lib\ and find file called tzmappings.

4. In tzmappings file try to find string with the name of system timezone (from point 2).

If you can not find appropriate string then you can add one yourself. For example,

Belarus Standard Time:929,929:BY:Europe/Minsk:

Where,

Belarus Standard Time - the Windows time zone registry key called TimeZoneKeyName (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation -> TimeZoneKeyName)

929,929 - time zone map ID

BY - the locale

Europe/Minsk - Java time zone ID

More information this (section 8.2.7 JRE Internal Representation of Time Zone Mappings)

5. Save file tzmappings and restart the ESM Console.

Hope this instruction will help you.

 

 

ianfitz Outstanding Contributor.
Outstanding Contributor.

Re: Console is not honoring the timezone of the machine i...

Hey this is probably an old thread but if you need to preserve normal operation of the bin\console.bat (ie Console is running on Windows), then create a new version of bin\console.bat (bin\console_mytz.bat) that you will launch to start the console from here on.

In your new bin\console.bat, copy the ARCSIGHT_JVM_OPTIONS=-Xms.... (as is normally seen in scripts\console.bat) but append at the end " -Duser.timezone=Australia/Sydney" (with no quotes - and obviously adjust to your desired TZ)

HTH,

Ian

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.