Highlighted
yurimurillo Absent Member.
Absent Member.
1013 views

Error while trying to connect ESM to Oracle Database

Jump to solution

Dear Protect724,

I have successfully installed ESM Manager 5.2 in RHEL 6.1 OS and ESM Console in the same machine. On another RHEL 6.1 machine I have installed an Oracle 11.2.0.2 database and created the arcsight instance. Everything seems to work fine (I can log into the database, succesfully run the manager, etc) but when ESM tries to connect to the database I come across an error that I haven't been able to fix yet.

Please find attached a copy of the error:

Oracle Host Name: *****

Oracle Port: 1521

Oracle SID: *****

Database User Name: arcsight

Database Password: *****

Are the values correct [yes/no/back/cancel]?yes

Connecting to database

Verifying schema

Error (Could not initialize class com.arcsight.common.persist.ReportTemplateValidator)

I have been searching through logs but I can't find anything relevant. Is this a known error? If so, how can be fixed?

Thank you very much!

Labels (1)
Tags (4)
0 Likes
1 Solution

Accepted Solutions
yurimurillo Absent Member.
Absent Member.

Re: Error while trying to connect ESM to Oracle Database

Jump to solution

I solved the problem by editing /etc/gdm/custom.conf and adding both DisallowTCP=false and AllowRemoteRoot=true under the [Security] tab and Enable=true under the [xdmcp] tab. After doing so I simply restarted X11 (init 3 && init 5) and now I can run the installer in GUI mode like a charm.

I hope this can help someone with the same problem.

Anyway, many thanks for your help Evgeny

0 Likes
5 Replies
Acclaimed Contributor.. lless Acclaimed Contributor..
Acclaimed Contributor..

Re: Error while trying to connect ESM to Oracle Database

Jump to solution

Try run install through GUI.

0 Likes
yurimurillo Absent Member.
Absent Member.

Re: Error while trying to connect ESM to Oracle Database

Jump to solution

Thanks for the response:

I've tried to do so, but the installer doesn't allow me to run in GUI mode: it just says

Wizard could not connect to an X11 display. Please set the DISPLAY variable to start the wizard in UI mode.

Falling back to console mode.

I find this odd since I've been able to run the rest of installations in GUI mode without any problems.

Could you give me a little insight on how to edit the DISPLAY variable?

Thank you very much

0 Likes
Acclaimed Contributor.. lless Acclaimed Contributor..
Acclaimed Contributor..

Re: Error while trying to connect ESM to Oracle Database

Jump to solution

try run "xterm" and through  him run install.

0 Likes
yurimurillo Absent Member.
Absent Member.

Re: Error while trying to connect ESM to Oracle Database

Jump to solution

I solved the problem by editing /etc/gdm/custom.conf and adding both DisallowTCP=false and AllowRemoteRoot=true under the [Security] tab and Enable=true under the [xdmcp] tab. After doing so I simply restarted X11 (init 3 && init 5) and now I can run the installer in GUI mode like a charm.

I hope this can help someone with the same problem.

Anyway, many thanks for your help Evgeny

0 Likes
kitdaddio Absent Member.
Absent Member.

Re: Error while trying to connect ESM to Oracle Database

Jump to solution

For Oracle jdbc connection string, be sure to use a forward slash (not colon) before the database_name:

jdbc:oracle:thin:@hostname_or_IP:1521/database_name

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.