Absent Member.
Absent Member.
2108 views

Export Package Fails: File content is too large

Jump to solution

Hi all,

when I try to export a package with only reports, I always get the error message "Export Failed: File content is too large". I have tried to shrink down the package as much as I can, even when just exporting a single report, I still get that error. There seems to be a limit of 30 MB.

Under advanced attributes, I have selected the "Export" format and ticked "Exclude Reference IDs" because I want to use that export as a backup for import into a different Manager.

Any idea why exporting even a single report takes so much space and how I can either reduce that size without losing necessary information or increase the file size limit of 30 MB?

Cheers

Jens

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Absent Member.
Absent Member.

seems that exporting just reports always also includes the archived reports. If you select the tab "Excluded Resource Types" and manually shift the "Archived Report" type to the "Exclude Types" list, the export works as desired.

I will probably never understand, when arcsight automatically resolves dependencies, and when not

Anyhow, this can be marked as "resolved" ... unless someone knows where that 30 MB limit is coming from?

Cheers

Jens

View solution in original post

0 Likes
4 Replies
Absent Member.
Absent Member.

seems that exporting just reports always also includes the archived reports. If you select the tab "Excluded Resource Types" and manually shift the "Archived Report" type to the "Exclude Types" list, the export works as desired.

I will probably never understand, when arcsight automatically resolves dependencies, and when not

Anyhow, this can be marked as "resolved" ... unless someone knows where that 30 MB limit is coming from?

Cheers

Jens

View solution in original post

0 Likes
Absent Member.
Absent Member.

Hello,

You can change that limit if you'll change a few properties in the file 'server.defaults.properties' in the path '%manager_home%/config'.

Search for properties related to export and packages.

You'll need to restart your Manager after the change.

Regards,

Or.

0 Likes
Absent Member.
Absent Member.

The setting you are after is archive.export.max.size=

Just stick that in server.properties and set an appropriate value (500MB)

Just as an FYI, you shouldn't change the values in server.defaults.properties, but copy the parameters you need from there into server.properties.

0 Likes

If you put these parameters into your managers' server.properties file and restart it, you will be able to import/export files up to 90 Mb size:

     persist.file.size.max=90

     archive.export.max.size=90000

A believe you could set this limit event to a bigger value without any negative consiquences (at least temporary).

The solution proposed earlier "Excluded Resource Types" is not universal, for example when you need to quickly migrate all custom content to another manager or preserve the data in active and session lists (identity information etc).

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.