ALERT! The community will be read-only starting on April 19, 8am Pacific as the migration begins. Read more for important details.
ALERT! The community will be read-only starting on April 19, 8am Pacific as the migration begins.Read more for important details.

Fatal Execption: Another Instance of arcsight smartagents is already running

Hi Guys

I need some help with an error in the arcsight smartconnector. I installed a smartconnector to collect logs from Sophos Anti-Virus DB but when I run the the service the connector in the console remains "down" . Checking the logs in the agent.out.wrapper I found the following error:

Another instance of ArcSight  SmartAgents is already running with base folder: C:/Program Files/ArcsightSmartconnectors/sophos/current. If this is incorrect, please delete the file:  C:/Program Files/ArcsightSmartconnectors/sophos/current/run/agent.lock

I deleted the mentioned file but still not working, it was the first time that I installed the connector. I killed the process manually but nothing.

Thanks for the help



Labels (1)
4 Replies
Fleet Admiral
Fleet Admiral

It sounds like you have two services installed using the same service name. By default, when you install a SmartConnector, it will give the service name a generic name - which isnt great. I see you have installed the SmartConnector in a unique folder, which is great, but I would go through the process of running the setup again (use 'arcsight agentsetup') and go through the process of making it stand alone (not having it run as a service) and then add it back in as a service - but make sure you give it a logical name such as 'Connector_Sophos' or something. That should be better.


Yes, that's exactly what happened but I dont understand why if it was the first time I installed that connector.

Thanks for your help Paul!!

Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

seems the installation was not completed in first attempt, have faced the similar issue in checkpoint integration which resolved by deleting current folder and fresh installation.

Commodore Commodore

Good Day,

Restart connector, while restarting delete the files agent*.lock, continuously.  From location /ArcsightSmartconnectors/sophos/current/run/agent.lock.

Hope this helps.



The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.