Commander Commander

Is there a way to set the max.request.size for kafka destiantions?

We are seeing this error on the connector

Is there a setting in that I am not seeing? I was unable to see anything related to max.size.request. The cefkafka settings for kafka destination all like they would allow large messages without this error showing up.


Connector sending to kafka:

ERROR: java.util.concurrent.ExecutionException: org.apache.kafka.common.errors. RecordTooLargeException: The message is 1105463 when serialized which is larger than the maximum request size you have configured with the max.request.size configuration


The event is still making it in full to the broker as well as ESM.


This is also a custom kafka setup, not transformation hub.

Labels (1)
2 Replies
Fleet Admiral
Fleet Admiral



the in of the SM you should be able to configure the following parameters:


but those are introduced starting with Smart Connector version 7.10. 

Verify which version did you have and if is lower then this version try to upgrade at least to SM 7.10.


Best Regards, 



Vice Admiral Vice Admiral
Vice Admiral


Just out of curiosity where did you find that parameter? I do not see it in the defaults.

VALUE_DESIRED? Wanted to test this but unsure of value sized used here.

Thank you
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.