Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class
478 views

Minimum requirements not met. ArcSight Express 4.0 Required

Jump to solution

I am doing an upgrade of a machine from ArcSight Express 3.0 to ArcSight Express 4.0 P1. The first part appears to have succeeded. The services are up and I am able to log in to the device using Console 4.0. The device seems to be doing its work.

Upon attempting the Express 4.0 patch 1 installation, it gave me an error:

"Minimum requirements not met.

Arcsight Express 4.0 is required to apply this patch"

The log file generated by the installer provided no clues and does not display any errors. Anyone had this experience?

Labels (1)
Tags (1)
0 Likes
1 Solution

Accepted Solutions
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Richard's finding was key. Prior to the upgrade, I had reset the mysql password for 'arcsight' in order to make a backup of the system tables. It turns out that the steps that I was given did not change the mysql password for 'root'. This meant that the 3.0 > 4.0 upgrade was not complete even though everything appeared to be fine. AE 4.0's connector appliance features had not yet been set up. The last part of the update was incomplete.

Support got me to log in to the DB and copy the hashed password of 'arcsight' to 'root'. We then proceeded with some recovery steps and completed the upgrade. I'll proceed with the patch tomorrow.

A way of verifying the 3.0 > 4.0 upgrade: check the build versions when checking the status of the ArcSight services "service arcsight_services status"

conapp:6.4.0.6711.2

  esm:6.1.0.1389.0(BE1389)

  storage:BL1124

  process management:4.0-1311

  installer:4.0-1311

View solution in original post

0 Likes
7 Replies
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

This device is running RHEL 5.5 (Tikanga).

0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Attached is 'log' and 'res' content of /opt/update

It seems to contain files created by the 4.0 update.

0 Likes
Vice Admiral Vice Admiral
Vice Admiral

Looks like the tz_update failed due to incorrect credentials for "root".

0 Likes

First before you go any farther --- make sure you do these things ----- if you already ran it and it failed open a Support Case as a Botched Upgrade can break anything else you do.

On the ArcSight Express 3.0 --- do a complete resource validation and correct all issues it returns

Than you need to upload the results of the your system tables .sh  script to ArcSight Support to validate for you --- this usually takes 2 weeks.

Than after its validated --- run the 4GB perl script that upgrades the Express 3.0 box to 4.0 ----

After that - ensure that the following all work correctly ----

YOUR EXPRESS:6443 ---- this should redirect to 8443  but there is an issue with some certs and you cant open Connector manager in the Admin Web console with out hitting 6443 first -----Your new free ConnApp 1 container 4 connectors - licensed to manage 4 internal or remote

YOUR EXPRESS:8443 --- Your Web Manager  -- make sure all your ICONS here load and work properly

YOUR EXPRESS:9443 ---- ArcSight WEB - make sure this works also

Log in via SSH and make sure all the ./arcsight service commands function and no SYMBOLIC links are broken

I would let this set for at least a week to ensure all your archiving and other automated reports and alerts work correctly

After that than apply Patch 1 -

0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Thanks for the tips, and Christopher. The 3.0 > 4.0 part is already done.

I did the resvalidate and had one 'instrument' which was invalid prior to the upgrade. Support advised that this could be ignored. I connected directly to the machine and did the upgrade. I was able to access using Console 4.0. I shall check out the other ports (6443 - never looked at this before & 9443) upon my next visit to the site.

arcsight_service commands function well. I'll update the news here.

0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Richard's finding was key. Prior to the upgrade, I had reset the mysql password for 'arcsight' in order to make a backup of the system tables. It turns out that the steps that I was given did not change the mysql password for 'root'. This meant that the 3.0 > 4.0 upgrade was not complete even though everything appeared to be fine. AE 4.0's connector appliance features had not yet been set up. The last part of the update was incomplete.

Support got me to log in to the DB and copy the hashed password of 'arcsight' to 'root'. We then proceeded with some recovery steps and completed the upgrade. I'll proceed with the patch tomorrow.

A way of verifying the 3.0 > 4.0 upgrade: check the build versions when checking the status of the ArcSight services "service arcsight_services status"

conapp:6.4.0.6711.2

  esm:6.1.0.1389.0(BE1389)

  storage:BL1124

  process management:4.0-1311

  installer:4.0-1311

View solution in original post

0 Likes
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

4.0 P1 applied successfully.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.