Highlighted
Fleet Admiral
Fleet Admiral
2061 views

Possible issues with ArcMC 2.93 and Connector 7.14 (Updated 07/01/2020)

UPDATE

"

The issue has been confirmed only for ArcMC 2.93, and not for the rest of the products. If you are facing issues with slowly increased CPU load that ends with the service needing a restart, please contact support to get a hotfix for this.

"

 

 

I want to bring to everyone's attention the current announcement, the issue has NOT been confirmed yet, and this post will be updated!

But in the case that you might be included, here is the current announcement. Anything new will be posted as a new post + updating this, so if you post or like this comment, you will automatically subscribe for updates.

Announcement:

Dear ArcSight Community,

As of 2019.12.18, we have identified an issue @ the latest version of ArcMC, which is ArcMC 2.93.

Currently, we are investigating the root causes of this issue.

We have reason to believe it is related to Zulu OpenJDK.

We are doing the proper due diligence to ensure other ArcSight product components are not affected.

Recommendation:

If you are considering installing ArcMC 2.93, we recommend that you install it on a Test environment first to ensure full functionality.

-----------------------------------------------------------------------------------------
All topics and replies made is based on my personal opinion, viewpoint and experience, it does not represent the viewpoints of MicroFocus.
All replies is based on best effort, and can not be taken as official support replies.
//Marius
18 Replies
Highlighted
Commodore
Commodore

Marius,

Wondering if you can provide some information on the potential issue (e.g. how it impacts the product)?

 

Thank You!

0 Likes
Highlighted
Commander Commander
Commander

as example our ArcMC after ~2 days starts consuming all CPU resources. Looks like everything works fine after that just GUI is sllllllloooooooow. Restart of arcmcd processes solve tahat for another 2 days.

It would be nice to have more info from MF than just generic sentence there is may be bug.

BTW same behaviour observed on two another installations.

SH   

0 Likes
Highlighted
Fleet Admiral
Fleet Admiral

Sorry for not getting back to you Stepan, but it needed to also be 100% sure what the issue was first, the initial post was solely to try to give the message out.

After more research, the issue seems to only impact ArcMC 2.9.3, due to a bug in the crypto library of Zulu JDK.

While my posts unfortunately cannot be taken as a official response, I do know that they are working on a patch, and until further notice you either have to downgrade to the earlier version or change out the JDK with the newest release from Zulu in the meantime.

-----------------------------------------------------------------------------------------
All topics and replies made is based on my personal opinion, viewpoint and experience, it does not represent the viewpoints of MicroFocus.
All replies is based on best effort, and can not be taken as official support replies.
//Marius
0 Likes
Highlighted
Commander Commander
Commander

Hello,

that's fine I fully understand that this is unofficial support and I really appreciate it.

it seams that base on azul web page jdk is current 8u232b18 so only posibility would be to downgrade it. I'll try tahat...

Thanks
Stepan

0 Likes
Highlighted
Fleet Admiral
Fleet Admiral

Just for reference, the issue was resolved in this release:

https://docs.azul.com/zulu/zulurelnotes/ZuluReleaseNotes/ReleaseDetails1135-842-bpr.htm

The issue which was fixed in this release was ZULU-5050.

-----------------------------------------------------------------------------------------
All topics and replies made is based on my personal opinion, viewpoint and experience, it does not represent the viewpoints of MicroFocus.
All replies is based on best effort, and can not be taken as official support replies.
//Marius
Highlighted
Knowledge Partner Knowledge Partner
Knowledge Partner

I installed both, 2.93 and connectors with 7.14. Seems like this causes 80%+ CPU usage on the ArcMC. I downgraded the connectors to 7.13... let´s see if that fixes the issue.

0 Likes
Highlighted
Knowledge Partner Knowledge Partner
Knowledge Partner

Even after the downgrade the appliance still ceases to work properly after several hours. I forgot to check CPU before I rebooted, will check again in 24h.

Maybe it is not 7.14 related but a general 2.9.3 issue?

0 Likes
Highlighted
Fleet Admiral
Fleet Admiral

The issue is indeed mostly related to 2.9.3, the issue itself is a bug in the new Zulu JDK. There should be an official fix on the way, but until then you will either have to downgrade ArcMC or change the JDK with the newest Zulu version (not an official support solution though).

-----------------------------------------------------------------------------------------
All topics and replies made is based on my personal opinion, viewpoint and experience, it does not represent the viewpoints of MicroFocus.
All replies is based on best effort, and can not be taken as official support replies.
//Marius
Highlighted
Lieutenant Lieutenant
Lieutenant

If you open a case support has a hotfix that will resolve the issue with 2.93. We experience the same issue over the holidays where CPU would ramp up around the 24 hour mark. Restarting all services also temporarily resolves the issue. 

Highlighted
Fleet Admiral
Fleet Admiral

Ah good to know, i just came back from the holidays, so did not know there was a hotfix already, will update the initial post!

-----------------------------------------------------------------------------------------
All topics and replies made is based on my personal opinion, viewpoint and experience, it does not represent the viewpoints of MicroFocus.
All replies is based on best effort, and can not be taken as official support replies.
//Marius
Highlighted
Knowledge Partner Knowledge Partner
Knowledge Partner

Do you happen to know if Framework 7.14 is also affected or just ArcMC? The hotfix fixed the ArcMC issue, however I wouldn´t want to apply it to all connectors when I upgrade.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.