Vice Admiral
Vice Admiral
1028 views

SCCM, SmartConnector, JDBC and Mixed Mode

Has anyone been able to connect to the SCCM DB via JDBC without setting the SCCM SQL DB to mixed mode?

I am on a Win2008R2 box.

My Domain Service Account was given access to the SQLDB via Windows Authorization.  When creating the SC, I chose JDBC (the only option it appears) and entered the following for JDBC Database URL

jdbc:sqlserver://<server>:1433;DatabaseName=<name>;integratedSecurity=true

and then the service account username and password.

The error I get back is this:

Connector table parameters did not pass the verification with error [0: Unable to open a connection to [jdbc:sqlserver://<server>:1433;DatabaseName=<name>;integratedSecurity=true]. (This driver is not configured for integrated authentication. ClientConnectionId:<xxxxxx>). Do you still want to continue?

Reading around on the interwebs, the suggested remedy for this says to put the 64bit sqljdbc_auth.dll in \<agent>\current\user\agent\lib which I have done.

But I still get the same error.

Security requirements prevent us from changing the server to mixed mode.

Suggestions?

Labels (1)
Tags (3)
0 Likes
5 Replies
Vice Admiral
Vice Admiral

More information: 

If it wasn't clear from the previous post, this SC is installed on a Windows 2008R2 box.

From this website: http://datacleaner.org/topic/94/Howto-connect-to-SQLServer-with-integratedsecurity

and this website: com.microsoft.sqlserver.jdbc.SQLServerException: This driver is not configured for integrated authentication. - Microso…

I found some suggestions on how to get java to work using integrated security and how to resolve that question.

Under %AGENT_HOME%\current\bin\scripts, there is a file called execjava.bat.  Looking through that file, it appears that that is the file that starts java and has the –Djava.libary.path= parameter.  I looked at the path listed there and copied the 64bit version of sqljdbc_auth.dll into that directory. 

Tried again, but got the same error.

Then, based on the datacleaner site, I modified the classpath to add the location of the sqljdbc_auth.dll.  But same error.

The latest attempt I did was adding to location of the sqljdbc4.jar to the windows path.  Still the same error.

If anyone else has suggestions, I'm willing to listen.

0 Likes
Lieutenant Commander
Lieutenant Commander

Hi Craig,

We have been facing the same issue during the connector installation. Even I tried adding sqljdbc_auth.dll in both agent/lib directory and in windows path.. but it didnt work.

Did you find a solution to this problem?

Regards, Hardik

0 Likes
Vice Admiral
Vice Admiral

I ended up opening a ticket with ArcSight support.  At the moment it appears that you MUST use mixed mode authentication for this to work.   I hope to get final confirmation from them today.

0 Likes
Lieutenant Commander
Lieutenant Commander

Hi Craig,

Did you get a response from the support?

In my case supports says that the Connector does not support integrated authentication and it has been acknowledged as a feature request.

0 Likes
Vice Admiral
Vice Admiral

Final answer copied below:

I apologize for the confusion. You're correct, for 'Microsoft System Center Configuration Manager' ODBC is not available for 'Microsoft System Center Configuration Manager DB' connector.


So, we are currently stuck.


Thanks all.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.