Highlighted
Super Contributor.
Super Contributor.
825 views

Smart Connector upgrade on ArcMC

Jump to solution

Hi.

I'm trying to upgrade a remote connector from ArcMC. The current version of the connector is 7.6, I will upgrade it to 7.11 version. When I checked the OS version of the connector servers, it is RHEL 6.2 which is not on the list of supported OS of 7.11 version. Should I upgrade the OS first before upgrading the connector?

And for 7.1 connector version, is there a path needed before I can upgrade it to 7.11 version or i can upgrade it directly?

Thanks and Regards,

Aqui

Labels (3)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Hello Aqui,

I would advise you to first upgrade the connector server RHEL version to the one supported as you will avoid any possible issues in the future.
Then, you can upgrade the connector.
But why do you want to upgrade it to 7.11 and not to the latest one, 7.13.2?
There is no path to be followed so you can upgrade it directly in any case.
If you are having connectors running on version 7.1, I would advise you to install new 7.13 connectors instead of upgrading it.
The reason for this is because of the Java version change. 7.1 is using version 7, while all connectors after 7.2.1 are using version 8.

I hope this answers your question.
Feel free to ask if you have anything additional to ask.

Regards,
Kresimir

View solution in original post

0 Likes
6 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Hello Aqui,

I would advise you to first upgrade the connector server RHEL version to the one supported as you will avoid any possible issues in the future.
Then, you can upgrade the connector.
But why do you want to upgrade it to 7.11 and not to the latest one, 7.13.2?
There is no path to be followed so you can upgrade it directly in any case.
If you are having connectors running on version 7.1, I would advise you to install new 7.13 connectors instead of upgrading it.
The reason for this is because of the Java version change. 7.1 is using version 7, while all connectors after 7.2.1 are using version 8.

I hope this answers your question.
Feel free to ask if you have anything additional to ask.

Regards,
Kresimir

View solution in original post

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Hi Kresimir,

I'll relay it to our customer. I think it's really best if we upgrade first the RHEL version of the connector server.

I'm thinking 7.11 first since that is the latest SC installed on our customer. But i'll upgrade it to 7.13 sooner.

One more thing, I tried to upgrade it locally but it didn't work as well, the error is saying that I cannot upgrade from 32-bit to 64-bit version of the connector. But when I checked, the machine is on 64-bit. Any reason behind it? I was looking for the 32-bit 7.11 connector version but it seems that everything is on 64-bit now.

Hope you can help me on this.

 

Thanks and Regards,

Aqui

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hello Aqui,

I'm glad I could help.

Regarding your second issue, it seems like you are having installed 32-bit connectors which are no longer available.
They were discontinued in April 2018. So you won't be able to upgrade 32bit to 64 bit and you also won't be able to find 32bit installation files anymore.
In order to check and be sure which version you have installed, you can read and follow the step from this post:
https://community.microfocus.com/t5/ArcSight-User-Discussions/Connector-32-bit-or-64-bit/td-p/1627241

So the best option would be to install a fresh connector, using the latest version.
Otherwise, you can try using the "Emergency Restore" option via ArcMC.
Again, more information can be found here:
https://community.microfocus.com/t5/ArcSight-User-Discussions/Migrate-from-32-bit-connector-to-64-bit-connector/td-p/1642340

Regards,
Kresimir

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Hi Kresimir,

This information is such a big help to me. Thank you so much! I'll discuss it with our customer and create an upgrade plan. Again, thank you!

 

Thanks and Regards,

Aqui

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Hi Kresimir,

I tried to update the current connector which is 7.10 64-bit to the latest version 7.13 but I still get the error of "Update from 32-bit to 64-bits is not allowed".

Is this a bug or something? Because i'm sure that I uploaded the 64-bit smart connector on the arcmc repositories as well as on the local folder.

Any thoughts on this?

Thanks and Regards,

Aqui

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hello Aqui,

Make sure that you have the 64-bit connector installed, usually, this message should not appear if you have a 64-bit upgrading to the 64-bit connector.
If you still think everything is correct, then I would suggest trying with the emergency restore I provided in the previous response.
Or if the connector you are talking about is Syslog, you can simply install fresh connector.
As the last step, you can open a ticket with support explaining the issue and providing current/user/agent and current/logs

Regards,
Kresimir

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.