Absent Member.
Absent Member.
3076 views

SmartConnector installation fails since version 6.0.1.6574

Hi all,

I am having serious issues installing SmartConnectors since version 6.0.1. I have tried all available 6.0.x versions, 6.0.1, 6.0.2 and 6.0.3, all give me the same result.

Vanilla RedHat 6.2 setup with all recommended libraries starting installation in console mode (SSHing into system, no X11 forwarding supported). Running the .bin file copies in "root" context, all the required Java-bruhaha in the specified path and asks to manually run "runagentsetup.sh". Running the script, again in "root" context, I get the following error:

[root@host]# ./runagentsetup.sh

Assuming ARCSIGHT_HOME: /opt/arcsight/sconnectors/syslog_udp/current

Assuming JAVA_HOME: /opt/arcsight/sconnectors/syslog_udp/current/jre

ArcSight Agent Setup starting...

Connector Setup Wizard starting in mode [CONSOLE]

[Wed Jun 19 14:05:07 UTC 2013] [INFO ] Checking for a running instance of connector...

[Wed Jun 19 14:05:07 UTC 2013] [INFO ] Starting up connector...

FATAL EXCEPTION:

Could not launch an instance of Connector

FATAL EXCEPTION:

No connector found at the specified port [10001]... exiting

[Wed Jun 19 14:07:08 UTC 2013] [ERROR] An instance of connector was launched, but communication was lost with it.

[Wed Jun 19 14:07:08 UTC 2013] [ERROR] You may need to shut it down manually.

[Wed Jun 19 14:07:08 UTC 2013] [INFO ] Shutting Down Agent Framework Version [6.0.3.6664.0]

In the agentinstall.log I can find loads of error messages, about "connection refused". Logfile is attached, if you want to inspect it for further information.

This is repeated until a timeout is reached. Every once in a while (about 1 out of 5 attempts), I do get a connection after a looong wait on "Starting up connector ...". However, I don't trust the resulting installation.

Is anybody else experiencing issues with smart connector installation timing out? What could be causing this long timeout issue? I tried small letter hostname, different domain, I double checked installed libraries and I have a support ticket open at hp. So far no results.

Cheers

JP

Labels (1)
0 Likes
25 Replies
Captain Captain
Captain

I tried 5.2.7 and 7.0.6 and still get the same issue.

my current entropy was about 128

0 Likes
Fleet Admiral Fleet Admiral
Fleet Admiral

You should try opening a second SSH session to the server and run "cat /dev/urandom | strings".

Let that stream while you try to install your SmartConnector.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.