Highlighted
kitdaddio Absent Member.
Absent Member.
630 views

jtds driver version error, to connect to Microsoft SQL Server 2008

I am using ArcSight FlexConnector ID-based DB connector.

It is to gather contents of an audit-log database table.

I am trying to use the jtds driver to connect to Microsoft SQL Server 2008 sp3 (x64)

FYI, Its class name is: net.sourceforge.jtds.jdbc.Driver

It is running in Linux environment

Anyway, I get a java error when I try to run the flexconnector:

Exception in thread "main" java.lang.UnsupprtedClassversionError: net/sourceforge/jtds/jdbc/Driver:

Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

                        .defineClassCond(ClassLoader.java:631)

   SecureClassLoader

   URLClassLoader

etc...

(I had to retype it, not copy-paste...)

Thanks

Kit Lueder

Labels (2)
0 Likes
5 Replies
kitdaddio Absent Member.
Absent Member.

Re: jtds driver version error, to connect to Microsoft SQL Server 2008

Hello???

I get a java error when I try to run the flexconnector:

Exception in thread "main" java.lang.UnsupprtedClassversionError: net/sourceforge/jtds/jdbc/Driver:

Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

                        .defineClassCond(ClassLoader.java:631)

   SecureClassLoader

   URLClassLoader

etc...

(I had to retype it, not copy-paste...)

Thanks

Kit Lueder

0 Likes
kitdaddio Absent Member.
Absent Member.

Re: jtds driver version error, to connect to Microsoft SQL Server 2008

I don't get the java version 51 error if I use the MS SQL JDBC driver version 4.0. I do get it with version 4.1.

I also got the error when I mistakenly used port # 1434 rather than port # 1433.

0 Likes
Regular Contributor.. vinicius.santos Regular Contributor..
Regular Contributor..

Re: jtds driver version error, to connect to Microsoft SQL Server 2008

Hi Christopher,

Did you have any advanced with this issue?

I had the same error. I tried use several version of jTDS driver but no success.

0 Likes
konrad.kaczkows1
New Member.

Re: jtds driver version error, to connect to Microsoft SQL Server 2008

I'm using JTDS 1.2.7

Newer version have some problems.

I works with MSSQL 2000/2005/2008/2012 and also with MSSQL CLuster [ where port is defined dunamically after every service restart/switch ]

JTDS file should be at:

current/user/agent/lib/jtds-1.2.7.jar

From agent.properties:

agents[0].JDBCDriver=net.sourceforge.jtds.jdbc.Driver

agents[0].databases[1].url=jdbc\:jtds\:sqlserver\://10.11.12.13\:1433/master;useKerberos\=true;domain\=domain.com

K.

K.
0 Likes
kitdaddio Absent Member.
Absent Member.

Re: jtds driver version error, to connect to Microsoft SQL Server 2008

I gave up on  the jtds and forced the system to use the built-in microsoft jdbc driver.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.