Outstanding Contributor.. rtoni1 Outstanding Contributor..
Outstanding Contributor..
534 views

ssh timeout after ArcMC RHEL upgrade

Jump to solution

Hello,

I have just upgraded a couple of ArcMC appliances to 2.9 in an attempt to address some bugs.  The appliance upgrade includes an updated RHEL 6.10 image which was also installed as per the instructions.

Now when I try to use SSH to connect to either of the upgraded systems (using various clients, e.g. puTTY, MobaXTerm, etc.) the session dies after about a minute - the server (ArcMC) "unexpectedly closes the network connection".

Anyone else experience something like this?  Seems like the updated O/S has some new SSH timeout or similar parameters baked in.  Maybe an easy fix...?  

Thanks,

0 Likes
1 Solution

Accepted Solutions
Knowledge Partner
Knowledge Partner

Re: ssh timeout after ArcMC RHEL upgrade

Jump to solution

Hi,


it looks like they enable ClientAliveInterval and configure it for 60 seconds.

The solution is disable it or increase the time.

To disable it navigate to /opt/local/openssh/config and comment the line "ClientAliveInterval 60" as following example : "#ClientAliveInterval 60" from sshd_config file. Save the configuration.

To increased the time edit sshd_config file from the same location and you can add 120 second. The line will look like this:

ClientAliveInterval 120

Do not forget to save the modification as well.

 

In both situations to be taken into consideration by the system the ssh process must be restarted.

To achieve this navigate to MC web page Administration -> System Admin -> SSH then chose Disabled to force the sshd process to stop.  Enabled again to make to be able to access using ssh the appliance.

 

Note: I observed the same behavior for Logger as well if you are installing the latest OS update RHEL 6.10. And must follow the same procedure if you want to disable it.


Until now i did not find the same behavior for the systems with RHEL 7.x because i don't have. But this that not means the problem it's not on RHEL 7.x as well.

 

Best Regards,

 

Daniel

4 Replies
Knowledge Partner
Knowledge Partner

Re: ssh timeout after ArcMC RHEL upgrade

Jump to solution

Hi,


it looks like they enable ClientAliveInterval and configure it for 60 seconds.

The solution is disable it or increase the time.

To disable it navigate to /opt/local/openssh/config and comment the line "ClientAliveInterval 60" as following example : "#ClientAliveInterval 60" from sshd_config file. Save the configuration.

To increased the time edit sshd_config file from the same location and you can add 120 second. The line will look like this:

ClientAliveInterval 120

Do not forget to save the modification as well.

 

In both situations to be taken into consideration by the system the ssh process must be restarted.

To achieve this navigate to MC web page Administration -> System Admin -> SSH then chose Disabled to force the sshd process to stop.  Enabled again to make to be able to access using ssh the appliance.

 

Note: I observed the same behavior for Logger as well if you are installing the latest OS update RHEL 6.10. And must follow the same procedure if you want to disable it.


Until now i did not find the same behavior for the systems with RHEL 7.x because i don't have. But this that not means the problem it's not on RHEL 7.x as well.

 

Best Regards,

 

Daniel

Outstanding Contributor.. rtoni1 Outstanding Contributor..
Outstanding Contributor..

Re: ssh timeout after ArcMC RHEL upgrade

Jump to solution

@Ionut Daniel Mosoiu - thanks so much for the very quick reply.  I will give that a try and return to mark that as the solution.  Much appreciated......

0 Likes
Outstanding Contributor.. rtoni1 Outstanding Contributor..
Outstanding Contributor..

Re: ssh timeout after ArcMC RHEL upgrade

Jump to solution

FWIW - just a follow-up.  It appears that it wasn't actually the RHEL upgrade to 6.10 that modified / added the timeout.  I updated the RHEL image on 2 remaining ArcMC appliances, and there was no impact on the SSH config etc.  Until after the ArcMC 2.9 install on same appliances - the config was modified and the session started to close after 60 seconds. 

Thanks again Daniel for the help.....   

Outstanding Contributor.. rtoni1 Outstanding Contributor..
Outstanding Contributor..

Re: ssh timeout after ArcMC RHEL upgrade

Jump to solution

Hi again,

Just confirming that I also saw the same behaviour on Logger appliances after upgrade to RHEL 6.10 and Logger 6.7.  Fixed using same solution provided by @Ionut Daniel Mosoiu (thanks again Daniel)

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.