Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Highlighted
KUlr7261 Absent Member.
Absent Member.
1350 views

Network Model Asset population to events

What I have done:

  1. I have followed the Network Model best practices as outlined in the attached. The Customer, Network, and Locations were all set up according to the guide and the Customer and Network have been added to all the Connectors, including the connectors for the loggers. This all took place before importing the Zones.
  2. We imported the Zones, Categories, and Assets using the method converting the CSV files to XML and importing into the manager.
  3. The Network "Zones" tab is populated with the custom Zones after import.

So, it looks as if everything has been done correctly. But there are still some Assets that are not populating (linking to Asset ID) in the events and the zones for the smartconnectors (under Original Agent field) are still showing up in the default zones instead of my custom zones and no asset ID is populating for that field (Original Agent). The assets that are not populating are coming from rsyslog and syslog sources over TCP and only show the device hostnames in the events (no device IP Addresses for example) and they do not show a zone at all. The smartconnector assets are populating when they are in the device hostname field for example, but not populating correctly for Original Agent.

If anyone has any idea why some assets are not populating correctly and/or how to fix this please let me know. We need the assets to be populating to the events in order for our queries/reports to work correctly.

Thank you

Labels (3)
0 Likes
Reply
2 Replies
KUlr7261 Absent Member.
Absent Member.

Re: Network Model Asset population to events

Oh, I forgot to mention that we are using a setup that has 2 managers, 2 databases, 2 loggers, and 2 smartconnectors for failover. A primary and secondary of each. The primary Manager is the AUP master. The user zones AUP is being pushed to the smartconnector agents, I just checked.

0 Likes
Reply
KUlr7261 Absent Member.
Absent Member.

Re: Network Model Asset population to events

Okay, my issue was fixed by editing the map.0.properties file on each of the connectors.

It was basically this:

"event.deviceHostName,set.event.deviceAddress

testhostname,192.168.10.11"

The hostname and IP address were added for every asset that was not poplulating to events. It worked right away.

0 Likes
Reply
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.