Highlighted
Respected Contributor.
Respected Contributor.
850 views

An error occurred when enabling fips mode for the ssl library

Hi All,

I am getting this warning sign when trying to login to AM -

"an error occurred when enabling fips mode for the ssl library"

Any idea what can cause this?

Thanks

0 Likes
8 Replies
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

No clue what could cause this.  FIPS is a new option to AM (ie. 9.5???) as I started seeing log entries for this whenever I re-started APM service.  Whatever comes oob never errored on me.  If you are not using this new option I do know it can be disabled under 'Edit\Options' menubar from the Client application.  This can be found under the Advance mode section so Hold 'Ctrl' keyboard key when selecting menubar option.

Hope this helps.

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

We are using AM 9.4 at the moment.

I found the advanced option from the edit--> options, but no specific name related to FIPS. Can you tell me the name whose value I have to change?

I am attaching a screenshot here.

Thanks.Advanced mode.PNG

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Interesting as mine shows...FIPS.png

 

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Searching help on FIPS shows the following entry "Using OpenSSL and OpenLDAP" which states from 9.40 FIPS capable.

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Even I am not really sure why this warning message is being displayed.

Although, when I opened the AM APM GUI, it shows -

2017/11/09 15:12:46.000    1    4    FIPS mode for the SSL library successfully enabled.
But no option for FIPS mode in the client.

Guess I will have to raise a ticket with Microfocus for this.

 

 

0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Check Automated process manager. There is an option to enable FIPS mode. Do Ctrl + Options.

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Hello NoSpoon,

I tried the Ctrl+ options under 'Tools' menu in APM GUI, but couldn't find anything related to FIPS. Can you provide a screenshot to point me where it is exactly located?

Thanks.

0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Can give a  try by declaring path variable for HP asset manager and restart the system?

I mean add this to "C:\Program Files (x86)\HPE\Asset Manager 9.60 en\x64" "Path" varaible avaible in Environment variable udner system vaiable


Sharath

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.