Highlighted
Super Contributor.
Super Contributor.
900 views

Issue with LDAP-AM integration [User's able to login to application without putting password]

Jump to solution

Hello Experts,

We have used AD authentication to login to Asset Manager application. It has been working well since the configuration done.
Today i have suddenly faced the issue regarding application login. As users may able to login to the AM application without putting their password.
We didn't performed any changes at configuration level.
Need urgent help on the same.

Attached database option setting snapshot and log file.

AM version : 9.63
Build 17050
OS : Windows 2012 R2 datacenter

Database: SQL server 2008

Regards,
Pooja Manjarekar

0 Likes
1 Solution

Accepted Solutions
Highlighted
Super Contributor.
Super Contributor.

Hello Experts,

Thanks for your suggestions!!

I need to specify the below additional settings to Administration -> Database Option ->LDAP authentication to

Authenticate AssetManager before user authentication

Default value: No
Current value:Yes
Used Value: Yes
Section (Internal Name) :LdapAuthentication
Option (Internal Name):LdapAuthenticateAMItself

Use LDAP authentication first, if it fails, use AM authentication
Default value: No
Current value:Yes
Used Value: Yes
Section (Internal Name) :LdapAuthentication
Option (Internal Name):UseLdapOrAM

Also I have set one default password for AM application login (so it will not except blank password).

Above changes worked in my enviornment!

Thanks,

Pooja Manjarekar

 

View solution in original post

0 Likes
4 Replies
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Sorry, I am not understanding the question.  Utilizing AD/LDAP usually entails "Use integrated NT security" checkbox.  This will disable the Password object.

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Please make sure that "Authorize anonymous LDAP connections (empty login without password)" current value is set to No, if it set to yes then user can login without putting the password.

Hope this helps!!!

Regards,

Indra

Indrakumar
0 Likes
Highlighted
Super Contributor.
Super Contributor.
Hello Experts
Kindly find attached snapshot of LDAP database option setting.
Authorize anonymous LDAP connections (empty login without password)" has already set to NO
Please check my setting and let me know if anything i missed out.

Regards.,
Pooja
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Hello Experts,

Thanks for your suggestions!!

I need to specify the below additional settings to Administration -> Database Option ->LDAP authentication to

Authenticate AssetManager before user authentication

Default value: No
Current value:Yes
Used Value: Yes
Section (Internal Name) :LdapAuthentication
Option (Internal Name):LdapAuthenticateAMItself

Use LDAP authentication first, if it fails, use AM authentication
Default value: No
Current value:Yes
Used Value: Yes
Section (Internal Name) :LdapAuthentication
Option (Internal Name):UseLdapOrAM

Also I have set one default password for AM application login (so it will not except blank password).

Above changes worked in my enviornment!

Thanks,

Pooja Manjarekar

 

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.