Highlighted
Super Contributor.
Super Contributor.
455 views

Urgent Help Needed- Assets Manager Links

Jump to solution

Hello Experts,

I'm currently working on customization part where i had to used links from 3 different tables to the 4th table.

I had created simple link and tried to call these link on the form. I can select and able to create the record on first time use. But when I tried to modify the same its thowing this error.

// Application: HPE Asset Manager 9.63.17050
// Executable: C:\Program Files (x86)\HPE\Asset Manager 9.60 en\bin\am.ovl
// User: AMUD/Admin

2018/03/22 13:17:34.537 2 1 [Thrd#:147756](-2006) ODBC error: [Microsoft][ODBC SQL Server Driver][SQL Server]Incorrect syntax near the keyword 'FROM'. SQLSTate: 37000
2018/03/22 13:17:34.537 2 1 [Thrd#:147756](-2006) ODBC error: [Microsoft][ODBC SQL Server Driver][SQL Server]Statement(s) could not be prepared. SQLSTate: 37000
2018/03/22 13:17:34.537 2 1 [Thrd#:147756](-2006) SQL statement 'SELECT TOP 1 FROM amCompanyTP C1 WHERE C1.lCompanyTPId = ?' could not be executed
2018/03/22 13:17:34.537 3 1 [Thrd#:147756](-2006) Parameter 0='42957702'
2018/03/22 13:17:34.553 2 1 [Thrd#:147756](-2006) ODBC error: [Microsoft][ODBC SQL Server Driver][SQL Server]Incorrect syntax near the keyword 'FROM'. SQLSTate: 37000
2018/03/22 13:17:34.553 2 1 [Thrd#:147756](-2006) ODBC error: [Microsoft][ODBC SQL Server Driver][SQL Server]Statement(s) could not be prepared. SQLSTate: 37000
2018/03/22 13:17:34.553 2 1 [Thrd#:147756](-2006) SQL statement 'SELECT TOP 1 FROM amApplications A1 WHERE A1.lApplicationsId = ?' could not be executed
2018/03/22 13:17:34.553 3 1 [Thrd#:147756](-2006) Parameter 0='43099331'

Snapshot attached for this error.

Can Anyone help me to resolve the same!!

0 Likes
1 Solution

Accepted Solutions
Highlighted
Super Contributor.
Super Contributor.

Hi,

This issue has been resolved now, by Adjusting the description string at table level using Designer application.  This element is located upper-right side above Validity. Need to select the String value for it.

View solution in original post

0 Likes
2 Replies
Highlighted
Honored Contributor.
Honored Contributor.

Hello poojam,
Hope you are doing well.

In accordance with the investigation I made to find a fix for this issue, you may create an index for the link between the tables. I found a previous ticket in which that procedure fixed the issue. Also when creating a new table it is necesary to put a value in the String field of the table.

Please test and let us know your results.

Best regards!

 

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution. If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the Thumb and show your appreciation.
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Hi,

This issue has been resolved now, by Adjusting the description string at table level using Designer application.  This element is located upper-right side above Validity. Need to select the String value for it.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.