IGOR_HPE Absent Member.
Absent Member.
2198 views

Asset Manager 9.50 WebService Error! NEED URGENT HELP

Jump to solution

Hello Experts,
After our WebService died on us, I tried to redeploy the WebService, only to see this error: 

Unable to connect to the database to retrieve the version. Please check the Web service's start-up parameters above and the parameters of the AssetManager connection in the 'amdb.ini' file.   Error (12,002): Connection failed. Please check the parameters and/or the description stored in the "amdb.ini" file.

 

I searched all over these forums and tried a multitude of solutions, only to come to the same error. The WebTier launches fine, but we cannot login because it relies on the Web Service. The aamapi95.dll does exist in the correct location.

Here is some information about our system:
Tomcat: Tomcat 7 (tried 8, same error) - 64bit
Java: Java 1.7.0_75 (64bit)
Server: Windows Server 2012 - 64bit
Engine: MSSQL 2012

The Windows Client works and its 32-bit ODBC connection. NEED URGENT HELP! I am trying to avoid re-installing Asset Manager 9.50.

0 Likes
1 Solution

Accepted Solutions
IGOR_HPE Absent Member.
Absent Member.

Re: Asset Manager 9.50 WebService Error! NEED URGENT HELP

Jump to solution

Ok, so we managed to resolve this error! I will post what worked for us:

1.) I made sure that both the names of the 32-bit and 64-bit ODBC connector matches
2.) I used this utility to make sure that the connectors work
3.) I made sure that the database name matches my connector names
4.) I changed my database password to match my server password (this is used while encrypting the passwords & makes it easier for me & because it worked)
5.) I edited the amdb.ini file to look like this:

[Connexions]
AM950=MSSQL
[AM950]
LongDesc=
Engine=MSSQL
Location=AM950
EngineLogin=sa
EnginePassword=00
EnginePassword2=myencryptedenginepasswordgoeshere,keepyours
ReadOnly=0
CacheDir=
CacheSize=5120000
Owner=
Base=AM950
ExpandTypedLinks=|amDocument|amWfWorkItem|amHistory|amReconcProposal
AmApiDll=C:\Program Files (x86)\HP\Asset Manager 9.50 en\bin\aamapi95.dll

6.) My WebService package.properties file:

AssetManager.UserLogin=Admin
AssetManager.UserPwd=
DB.engine=MSSQL
DB.datasource=AM950
DB.login=sa
DB.password=
DB.cache.enabled=true
DB.cache.dir=/tmp
DB.cache.size=1048576
DB.owner=
WebService.LoadOnStartup=Head/*
promptForPwd=true
encrypt=true

7.) Tomcat 7 Settings:

JVM path: C:\Program Files\Java\jdk1.7.0_79\jre\bin\server\jvm.dll
Java Classpath: C:\Program Files\Java\jdk1.7.0_79\lib\tools.jar;C:\Tomcat7AMWS\bin\bootstrap.jar;C:\Tomcat7AMWS\bin\tomcat-juli.jar
Java Options: -Dcatalina.home=C:\Tomcat7AMWS
-Dcatalina.base=C:\Tomcat7AMWT
-Djava.endorsed.dirs=C:\Tomcat7AMWT\endorsed
-Djava.io.tmpdir=C:\Tomcat7AMWT\temp
-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
-Djava.util.logging.config.file=C:\Tomcat7AMWS\conf\logging.properties
-Dsun.lang.ClassLoader.allowArraySyntax=true
-Djava.library.path=C:\Program Files (x86)\HP\Asset Manager 9.50 en\x64

Initial Memory: 512MB
Max Memory Pool: 1024MB
Thread Stack Size: 1000KB

In the Startup and Shutdown tabs, I removed the "Working Path" for both WT and WS.
Log On tab > Log on as: Local System Account
*NOTE: for Java Options, WebTier (WT) and WebService (WS) have their own relative paths except for catalina_home

Also, when redeploying the WS, remove Tomcat Cache & I inputted my passwords during deployment (prompts for them). Oh and I did run "Check web definitions" and Tagged the service, but it didn't help me. I followed the manual strictly, but that was of little help.

View solution in original post

0 Likes
5 Replies
IGOR_HPE Absent Member.
Absent Member.

Re: Asset Manager 9.50 WebService Error! NEED URGENT HELP

Jump to solution

Does anyone have any advice? I already tried re-installing Asset Manager twice and still keep getting the same error. At one point I was able to see a slightly different error, but it was in regards to the ODBC. Any assistance will help!

Thanks!!!

 

0 Likes
Micro Focus Contributor
Micro Focus Contributor

Re: Asset Manager 9.50 WebService Error! NEED URGENT HELP

Jump to solution

What's your current connection string? Could you post here?

 

Usually 64bit java need to work with the 64bit dll files: the aamapi.dll located in x64 folder of your Asset Manager.

And you need to configure 64bit ODBC for connection.

0 Likes
Highlighted
IGOR_HPE Absent Member.
Absent Member.

Re: Asset Manager 9.50 WebService Error! NEED URGENT HELP

Jump to solution

I am not sure if the connection string will help, but here it is:

 

This is the connection string in the Web.xml of WebService:

<env-entry>
<description>AssetManager Database name</description>
<env-entry-name>AssetManager.DB.Name</env-entry-name>
<env-entry-type>java.lang.String</env-entry-type>
<env-entry-value>[MSSQL;AM950;;;;sa;cwY/W2Z8IwQ=;1;/tmp;1048576;AmApiDll='C:/PROGRA~2/HP/ASSETM~1.50E/x64/aamapi95.dll';ExpandTypedLinks='|amDocument|amWfWorkItem|amHistory|amReconcProposal']</env-entry-value>
</env-entry>

This is how I was able to successfully test the connection with this connection string: 

DSN=AM950;UID=sa;PWD=TEST123;APP=Microsoft® Windows® Operating System;WSID=WIN-NPI-VM111;DATABASE=RosevilleAM_950

The 64-bit ODBC connection was configured successfully and passes its tests when you test it (during creation, there is a test at the end). So I am not sure why it's failing. Could it be possibly that Asset Manager's driver (HP Asset Manager 9.50 en Driver) is corrupt even if I re-installed the application fully?

0 Likes
matthewpmattson Absent Member.
Absent Member.

Re: Asset Manager 9.50 WebService Error! NEED URGENT HELP

Jump to solution

It should also be noted that we are able to login to the Asset Manager Windows client using the same database. We have also tested the 64-bit connector using a Windows utility. Another interesting thing we observe is that we cannot deploy the adblog for Asset Manager Web. It prompts for the Admin credentials but they do not authenticate even though these same credentials work for logging into the Asset Manager Windows client.

0 Likes
IGOR_HPE Absent Member.
Absent Member.

Re: Asset Manager 9.50 WebService Error! NEED URGENT HELP

Jump to solution

Ok, so we managed to resolve this error! I will post what worked for us:

1.) I made sure that both the names of the 32-bit and 64-bit ODBC connector matches
2.) I used this utility to make sure that the connectors work
3.) I made sure that the database name matches my connector names
4.) I changed my database password to match my server password (this is used while encrypting the passwords & makes it easier for me & because it worked)
5.) I edited the amdb.ini file to look like this:

[Connexions]
AM950=MSSQL
[AM950]
LongDesc=
Engine=MSSQL
Location=AM950
EngineLogin=sa
EnginePassword=00
EnginePassword2=myencryptedenginepasswordgoeshere,keepyours
ReadOnly=0
CacheDir=
CacheSize=5120000
Owner=
Base=AM950
ExpandTypedLinks=|amDocument|amWfWorkItem|amHistory|amReconcProposal
AmApiDll=C:\Program Files (x86)\HP\Asset Manager 9.50 en\bin\aamapi95.dll

6.) My WebService package.properties file:

AssetManager.UserLogin=Admin
AssetManager.UserPwd=
DB.engine=MSSQL
DB.datasource=AM950
DB.login=sa
DB.password=
DB.cache.enabled=true
DB.cache.dir=/tmp
DB.cache.size=1048576
DB.owner=
WebService.LoadOnStartup=Head/*
promptForPwd=true
encrypt=true

7.) Tomcat 7 Settings:

JVM path: C:\Program Files\Java\jdk1.7.0_79\jre\bin\server\jvm.dll
Java Classpath: C:\Program Files\Java\jdk1.7.0_79\lib\tools.jar;C:\Tomcat7AMWS\bin\bootstrap.jar;C:\Tomcat7AMWS\bin\tomcat-juli.jar
Java Options: -Dcatalina.home=C:\Tomcat7AMWS
-Dcatalina.base=C:\Tomcat7AMWT
-Djava.endorsed.dirs=C:\Tomcat7AMWT\endorsed
-Djava.io.tmpdir=C:\Tomcat7AMWT\temp
-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
-Djava.util.logging.config.file=C:\Tomcat7AMWS\conf\logging.properties
-Dsun.lang.ClassLoader.allowArraySyntax=true
-Djava.library.path=C:\Program Files (x86)\HP\Asset Manager 9.50 en\x64

Initial Memory: 512MB
Max Memory Pool: 1024MB
Thread Stack Size: 1000KB

In the Startup and Shutdown tabs, I removed the "Working Path" for both WT and WS.
Log On tab > Log on as: Local System Account
*NOTE: for Java Options, WebTier (WT) and WebService (WS) have their own relative paths except for catalina_home

Also, when redeploying the WS, remove Tomcat Cache & I inputted my passwords during deployment (prompts for them). Oh and I did run "Check web definitions" and Tagged the service, but it didn't help me. I followed the manual strictly, but that was of little help.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.