Azzura Gun Trusted Contributor.
Trusted Contributor.
839 views

Asset Manager Web Service Not Working

I just re-deploy Asset Manager Web Service, but when I go to the URL, it says that the URL does not exist 
I got the 404 Error code. 

The deploy proccess has done successfully but it's not working

The webtier (localhost:8080/AssetManager) is working normally 

But the web service (localhost:8080/AssetManagerWebService) not working and got 404 error code. 

Any suggest? 

Thanks,

0 Likes
6 Replies
Acclaimed Contributor.. Mark Cullen_1 Acclaimed Contributor..
Acclaimed Contributor..

Re: Asset Manager Web Service Not Working

Have you used Designer application to execute "Tag web service..." under Action menubar?

Have you used Client application to execute "Check definitions of the Web services..." action wizard?

Even though WebTier works normally, are you able to log in and browse?

Has Java updated itself to a new version?  This could impact the java properties as the new version has different folder names.

Did you review any log files for errors?

I have a customer with simple Web Service setup using Java and Apaches TomCat practically identical to basic setup from manual.  We have a Windows 2012 R2 server and below are the steps I use whenever re-deploying...

1 - Stop "Apache Tomcat 8.0 Tomcat80" service (via 'Monitor Tomcat' or Services)
2 - Delete AssetManagerWebService.war file from "C:\Tomcat80\webapps"
3 - Delete AssetManagerWebService folder from "C:\Tomcat80\webapps" and "C:\Tomcat80\work\Catalina\localhost"
4 - Start Command Prompt (Admin) - right-click Start/Windows button (lower left corner)
5 - Execute the following command to change directory prompt:  cd C:\Program Files (x86)\HP\Asset Manager 9.50 en\deploy
6 - Execute the following command to deploy:  deploy.bat /x64 ..\websvc\package.properties
7 - When prompted, enter database password for database owner
8 - When prompted, enter user password for Asset Manager administrator
9 - When process complete, exit out of command prompt.  Ensure "BUILD SUCCESSFUL" stated else review for issues
10 - Copy AssetManagerWebService.war file from "C:\Program Files (x86)\HP\Asset Manager 9.50 en\websvc" and paste to "C:\Tomcat80\webapps"
11 - Start "Apache Tomcat 8.0 Tomcat80" service (via 'Monitor Tomcat' or Services)
12 - Open Internet Explorer and confirm success http://localhost:8080/AssetManagerWebService (could take up to 10 minutes for screen to display)

Azzura Gun Trusted Contributor.
Trusted Contributor.

Re: Asset Manager Web Service Not Working

I have used Desginer apps to Tag Web Service client to check definitions of the web services.. 

I'm unable to log in because the webservice is down.

I've updated the Java and Tomcat to the latest version.

I review the log files and did not find any error.

Thank you so much for give me detail steps to re-deploy. But I have done the same step before and it did not works.

0 Likes
Acclaimed Contributor.. Mark Cullen_1 Acclaimed Contributor..
Acclaimed Contributor..

Re: Asset Manager Web Service Not Working

If you have updated Java/TomCat to latest version have you confirmed these versions are supported from the compatibility matrix?  With these new versions have you stepped through "installing AM web" for the first time, again?  Could the port have changed to 8081?

0 Likes
poojam Super Contributor.
Super Contributor.

Re: Asset Manager Web Service Not Working

Hello,

Could you please provide the latest tomcat8.x_stdout.2018-05-11.log file and the error snapshot.

Regards,

Pooja

0 Likes
Highlighted
Azzura Gun Trusted Contributor.
Trusted Contributor.

Re: Asset Manager Web Service Not Working

I've attached the files you requested before. 
Thanks, 

0 Likes
Acclaimed Contributor.. Mark Cullen_1 Acclaimed Contributor..
Acclaimed Contributor..

Re: Asset Manager Web Service Not Working

Thank you for supplying the TomCat log files.

Was this working before or is this a first time setup?

Since you are using/deploying with x64, please confirm Data Source Name is created correctly under System DSN of ODBC Data Source Administrator (64-bit) and not ODBC Data Source Administrator (32-bit).

Upon opening stdout file, the first error (right at the top) relates with "Data source name not found and no default driver specified".  This relates with package.properties file parameter "DB.datasource="

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.