Trusted Contributor.. Hope Trusted Contributor..
Trusted Contributor..
491 views

Connect-it 9.80 russian encoding characters

Jump to solution

Hi there!

I have a mistake with character encoding.   I have csv file with russian language.  When I try to get the names colums I see them correctly. But when i starts connection scenario all symbols are transformed to (???????).

I tried to change the encodings, but it did not help.

Have any advice?

Kindly Help!!!!

Regards,

Hope

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Connect-it 9.80 russian encoding characters

Jump to solution

sorry, did not notice the screenshots before my first reply.

When you go through the configuration of the descriptor there will be a descriptor file (.dtd) created.

Can you check the file if it defines the (correct) encoding in the header? Something like this:

  <?xml version="1.0" encoding="UTF-8"?>

or

<?xml version="1.0" encoding="ISO-8859-1"?> (modify 8859-1 to your codepage number)

 

0 Likes
2 Replies
Micro Focus Expert
Micro Focus Expert

Re: Connect-it 9.80 russian encoding characters

Jump to solution

Hi Hope,

not much details do advice specifically but let's share some common configuration issues...

Basically you need to make sure that you have the same encoding end to end.

(As far I remember UTF is the recommended way.)

This is an example for MSSQL/SM:

  1. reset MSSQL to support Russia characters , then set 1252 codepage in CIT
  2. Or set sm to support UTF-8 , then set 65001 in CIT.

 I guess Excel get the code page settings from the OS so you need to check there.

Please check (all) your connectors for a code page setting. Different connectors may have own settings for it.

  • for SM connector you should see something like this in "cit.ini"
    • ,this option sets the codepage 1252 or 65001for SM connector: "/pifcon/sccon/ScDatabaseCodePage=1252"

Also are you sure that your target tool has the correct settings?

You did not mention where you import to.

You can verify this if you insert such chars directly in the tool, safe, go to another record and back to the record you just changed - are the char's still correct? (have seen an example in SM where the special chars did show ?? in the client after this test).

For AM there is a display issue which can be solved with this setting:

in am.inI add in the option section:

[Option]
/Advanced/UseHardCodedFontMapper=1
[FontSubstitutes]
MS Sans Serif=Arial Unicode MS

So as you can see many places end to end where this can get wrong.

If the above does not help you may open a support ticket to analyze the complete configuration.

Hope this helps
Kind regards
Volker

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Connect-it 9.80 russian encoding characters

Jump to solution

sorry, did not notice the screenshots before my first reply.

When you go through the configuration of the descriptor there will be a descriptor file (.dtd) created.

Can you check the file if it defines the (correct) encoding in the header? Something like this:

  <?xml version="1.0" encoding="UTF-8"?>

or

<?xml version="1.0" encoding="ISO-8859-1"?> (modify 8859-1 to your codepage number)

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.