Atul72 Absent Member.
Absent Member.
96 views

Error while creating Portfolio Item

Dear Experts,

We are using Asset Manager 5.10 build 6441 and DB is SQL Server 2005.

Configurations Done:

We have configured one workflow which automatically triggers an messaging action (mail notification) once the new Portfolio Item is created.

Problem Description: when we are trying to create a protfolio item on the AM Server directly, it is creating the items successfully along with mail notifications.

But when we are trying to create the item on some client machine we are getting the following error:-

2009/06/19 12:06:26.000 0 1 [Thrd#:3540](0) Message not sent to 'admin-assetmanager-@xyz.co.in': messaging not available
2009/06/19 12:06:26.000 0 1 [Thrd#:3540](0) Message not sent to 'Admin': messaging not available
2009/06/19 12:06:26.000 0 1 [Thrd#:3540](0) Message not sent to 'HarjeetAdmin': messaging not available
2009/06/19 12:06:26.000 0 1 [Thrd#:3540](0) Action 'New Portfolio Item Creation Action' failed to execute
2009/06/19 12:06:26.000 0 1 [Thrd#:3540](0) Error executing action from activity 'New Portfolio Item Creation' in workflow 'Portfolio Item Creation'.
2009/06/19 12:06:26.000 0 1 [Thrd#:3540](0) Unable to create ' DX6120 (DL-062009-2-LN-0000124::003830)' in table 'Portfolio items (amPortfolio)'.


Please suggest how to solve the same.I am attaching the screen shots of the workflow and the errors.


Further, while defining the workflow under activation conditions we have defined Post-Insert then why it is trying to execute the action before creation of the Portfolio item.


Thanks and Regards,
Atul Gupta
0 Likes
3 Replies
Absent Member.. MTWalsh Absent Member..
Absent Member..

Re: Error while creating Portfolio Item

It looks like Messaging needs to be configured on the client, or the action sending the message needs to be part of a workflow activity set to run at the server.
0 Likes
Atul72 Absent Member.
Absent Member.

Re: Error while creating Portfolio Item

Hi Walsh,

Thanks for reply.
Let me clear one more thing as while creating the workflow i used the option as Post Insert.

Then why it's trying to send the mail first and after that it creating the portfolio item.
0 Likes
Absent Member.. MTWalsh Absent Member..
Absent Member..

Re: Error while creating Portfolio Item

My guess (and it is a guess) would be that it would be because the record is being created ok until the mail fails, then being rolled back after that. Either that, or maybe the log is backward from what it looks like. You'd probably have to open a ticket to find that one out.

Michael
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.