Highlighted
Azzura Gun Trusted Contributor.
Trusted Contributor.
456 views

Failed to Patch Asset Manager 9.63

I want to patch HP Asset Manager 9.60 to 9.63 Version

But I failed, this is the error message:

M : amsrv/bin/amsrv.exe
Updating "D:\Program Files (x86)\HPE\Asset Manager 9.6
......
Ah oh! Failed to apply patch to "D:\Program Files (x86
n\", for more details please refer to "D:\Program File
9.60 en\patch_logs\patch.log"
Exception in thread "main" java.lang.NoClassDefFoundEr
peConverter
at com.hp.cm.dp.HashUtil.checksum(HashUtil.jav
at com.hp.cm.dp.DeltaPatch.copyFile(DeltaPatch
at com.hp.cm.dp.DeltaPatch.applyPatch(DeltaPat
at com.hp.cm.dp.DeltaPatch.main(DeltaPatch.jav
Caused by: java.lang.ClassNotFoundException: javax.xml
at java.base/jdk.internal.loader.BuiltinClassL
urce)
at java.base/jdk.internal.loader.ClassLoaders$
nknown Source)
at java.base/java.lang.ClassLoader.loadClass(U
... 4 more

 

Any suggest?

Thanks

0 Likes
3 Replies
Jason_Dowd Acclaimed Contributor.
Acclaimed Contributor.

Re: Failed to Patch Asset Manager 9.63

It looks like portions of that error message are missing, so I can't be sure.. Can you attach the patch.log referenced in the error?

Jason Dowd
HPE Software Support

If this post has helped you resolve the issue, please flag it as solved.
0 Likes
Azzura Gun Trusted Contributor.
Trusted Contributor.

Re: Failed to Patch Asset Manager 9.63

I've attached the log file

Thanks for your help. 

0 Likes
Jason_Dowd Acclaimed Contributor.
Acclaimed Contributor.

Re: Failed to Patch Asset Manager 9.63

So based on the log file, the failure is not helpful.

Updating "D:\Program Files (x86)\HPE\Asset Manager 9.60 en\amsrv/bin/amsrv.exe" ......
Ah oh! Failed to apply patch to "D:\Program Files (x86)\HPE\Asset Manager 9.60 en\", for more details please refer to "D:\Program Files (x86)\HPE\Asset Manager 9.60 en\patch_logs\patch.log"

It looks as if the combination of \ and / in the path may confuse the updater, but since there's no actual error message or clue as to why it failed, I'm perplexed.

Did you open up the command window as Administrator?

Jason Dowd
HPE Software Support

If this post has helped you resolve the issue, please flag it as solved.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.